• Since updating Yoast SEO, there are javascript errors when editing a page and text block element contents are uneditable.

    The js error is:

    Uncaught ReferenceError: wpseoShortcodePluginL10n is not defined
        at HTMLDocument.<anonymous> (kc.builder.js?ver=2.9.5:7136)
        at i (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.4.2:2)
        at Object.fireWith [as resolveWith] (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.4.2:2)
        at Function.ready (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.4.2:2)
        at HTMLDocument.J (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.4.2:2)

    The error disappears when disabling either Yoast SEO or KingComposer.

    Also reported to Yoast here: https://wordpress.org/support/topic/uncaught-referenceerror-wpseoshortcodepluginl10n-is-not-defined/

Viewing 15 replies - 1 through 15 (of 15 total)
  • I am also face same issue.

    • This reply was modified 4 months, 1 week ago by nidhik0105.

    Temporary solution: Remove or commet js in Plugin kingcomposer/assets/js/kc.builder.js
    line 7135 to 7177.

    But I hope a update for Compatible all plugin…

    We’ve fixed this in our current codebase (https://github.com/Yoast/wordpress-seo/pull/15717), the Yoast 14.7 release should bring backwards compatibility that fixes this issue.

    when selecting “Text Block” element to use in post/page shows Tinymce Error! and nothing can be written using the text block, when yoast is inactive this Tinymce Error! disappears and show as like before. This error come if kingcomposer and yoast seo is active.

    And “TypeError: Cannot read property ‘get’ of undefined” – error of kc.tools.js show in console

    Please help in high priority

    • This reply was modified 4 months, 1 week ago by nidhik0105.

    ” Temporary solution: Remove or commet js in Plugin kingcomposer/assets/js/kc.builder.js
    line 7135 to 7177.

    But I hope a update for Compatible all plugin… ”

    This doesn’t work either!

    solmediapl

    (@solmediapl)

    Thanks, this temporary solution works!

    teichhorst

    (@teichhorst)

    Hi there,

    I’ve tried the workaround and the fix – both didn’t work. I don’t want to deactivate Yoast, not even temporarily, but as it stands I’ld have to.

    Are there any news on this topic? I have multiple sites where this is happening.

    Regards
    Tim

    mthedesigner

    (@mthedesigner)

    Any updates? two sites not working due to this issue?????

    dale668

    (@dale668)

    Hello!
    Have the same issue after updating to 14.6.1
    When will you fix the bug? I also have a lot of sites with both of plugins.

    Best regards

    Hello There,

    Any update on this?

    Yes, I can confirm I have the same problem, where is the update? I have been waiting for the fix to this issue, which was reported two weeks ago.

    I posted for help due to Yoast plugin JS conflict with King Composer Tinymce Error, after the yoast update this issue showed up, as i could not edit my pages so i fond a temporary solution to make things work:

    1) go to admin menu SEO > Search Appearance > Content Types
    2) for me the error occurred when i tried to edit pages, so i from Content Types > Pages
    i switched to “Hide” for option “Show SEO settings for Pages” then click Save.

    Yoast meta option from page backend was gone so the Tinymce Error was also gone, then after you edit the pages contents you can switch back to “Show” for option “Show SEO settings for Pages” then click Save, and meta yoast option will re-appear on pages.

    —————————————————-
    my previous asking for help thread https://wordpress.org/support/topic/tinymce-error-conflict-with-king-composer-plugin/

    when king composer is active with yoast SEO, selecting “Text Block” element to use in post/page shows Tinymce Error! and nothing can be written using the text block, when yoast is inactive this Tinymce Error! disappears and it can be useable like before.
    This happened few days back it was OK before that.

    Please HELP!!
    —————————————————

    @razmi thanx for your solution but does not works for me.
    I try to disable Yoast Seo but nothing change.
    PHP ver. 7.0, 7.2, 7.3 same problem.

    How can I do?

    • This reply was modified 1 week, 6 days ago by simonshield.

    Hi @simonshield, you need to update your Yoast SEO Version to the latest. 🙂

    @simonshield Yes you can update the plugins, my solution was temporary.

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.