Support » Plugin: Swift Performance Lite » Conflict with Yoast meta name description – causes issues with Google!

  • Resolved mgraf

    (@pinot-fish)


    After hours of debugging which I initially thought was Yoast SEO, it turns out it is Swift. This recent version causes an issue with the meta name value for the description field. Note the extra space between the open parenthesis and the word “description”

    <meta name=” description” content=”

    This causes Google not to recognize the page description values! The odd thing is, this only happens when logged out of wp-admin. It shows OK while logged in. I went through and deactivated every other plugin I have, and narrowed it down to Swift conflicting with Yoast (tried Yoast versions 9.5, 9.4, 9.3).

    This extra space completely disappears simply by deactivating Swift. Checked across 3 different browsers. Note I did not have any of the minification settings enabled. I was only using the cache features.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi, try deactivate “Fix Invalid HTML” option in Optimization settings, meta-description went back to normal for one user with the very similar issue.

    Plugin Author swte

    (@swte)

    Try to disable Fix invalid HTML option

    This appears to have fixed the issue, thank you!

    mabdelmawgood

    (@mabdelmawgood)

    @swte I’m trying to disable Fix invalid HTML option with no luck. I try to disable it, save changes but it never saves. When I go back to the settings it still shows it as enabled.

    Any clue?

    lmsm76

    (@lmsm76)

    Just had the same issue and I confirm that it was fixed with – deactivate “Fix Invalid HTML” option in Optimization settings (Advanced View)

    Hi, I have the same problem but I don’t know where to find this “Optimization settings (Advanced View)”.
    You can help me?

    @nicholasferri

    Swift Performance Light
    Settings
    On the right side you have “Single View” | “Advanced View”
    Choose “Advanced View”
    Then on the left click on “Optimization” and you will find the option “Fix Invalid HTML”
    Just desactivate and your problem its solved.

    On the last days I have done this at about 10 websites, they were all with ” description” issue.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.