Support » Plugin: GiveWP - Donation Plugin and Fundraising Platform » Conflict with Yoast and Give

  • Resolved CherylS

    (@cheryls)


    When Yoast SEO is activated and I try to create a new form, I get this message:

    Warning: Invalid argument supplied for foreach() in /home/forgetm5/public_html/wp-content/plugins/wordpress-seo/admin/metabox/class-metabox.php on line 937

    When Yoast SEO is inactive, it’s fine.

    How can I rectify this situation?

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Ben Meredith

    (@benmeredithgmailcom)

    Hi there,

    I’m happy to dig in here.
    What version of Yoast SEO are you using, and what version of Give?

    We’ve had other reports of this in the past, and this is something I’d recommend you reach out to the folks at Yoast, since their plugin is the one mentioned in the error message. Make sure you are on the latest versions of all plugins before reaching out to them.

    It’s most likely a combination of multiple plugins creating that conflict — not just Yoast + Give (because we have thousands of users using both without that problem arising).

    I’d suggest using the Health Check plugin to troubleshoot that. It will allow you to deactivate all plugins and put your site on a default theme ONLY for yourself — your live visitors will not see that. We have a write-up on that here:
    https://givewp.com/documentation/resources/troubleshoot-wordpress-websites-health-check/

    Then you can enable plugins one at a time and test again until you see the problem again. Then let me know which plugin caused the conflict and I can take a closer look at replicating the issue for you.

    Thanks!

    Give – 2.4.7
    Yoast – 11.5

    I did run the Health Check plugin and the error only occurs when Give and Yoast are both activated. The only new thing is the Give plugin.

    Just updated Yoast, but no change. With ONLY Health Check and Yoast activated, the same error message occurs.

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Hi @cheryls — we have many thousands of users using Yoast and GiveWP, including our own givewp.com website and we can’t replicate that problem. Perhaps then it’s a conflict with those two plus your theme?

    Can you provide us with your System Info so we have a fuller understanding of your environment? That’s found in “Donations > Tools > System Info” Thanks!

    Plugin Support gsamsmith

    (@gsamsmith)

    Hi there,

    I’m going to mark this ticket as resolved, but if there is anything else you need don’t hesitate to reach out.

    Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.