Support » Plugin: Shortcode Factory » Conflict with Yoast 7.7

  • Resolved panpan2

    (@panpan2)


    Hi there- avid user of your plugin in the last few years!

    We are using Yoast on our site and their latest update is creating a conflict with this plugin – basically cannot edit any of the snippet descriptions.

    Wondering if you will be issuing a fix on this?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author WPMadeasy

    (@wpmadeasy)

    Thank you for bringing this up, we’re already looking into the matter and will release an update soon with some other fixes and updates.

    Thanks again for your patience, stay tuned.

    Plugin Author WPMadeasy

    (@wpmadeasy)

    Hi there, after very intensive research, our team has finally concluded that the issue isn’t due to our plugin, but is on Yoast SEO plugin side. In fact, there’s not a single issue but a lot of conflicts in their accompanying JavaScript files/code.

    There are also different variations/combinations of these. For example, if you first try to edit the snippet title then you can edit the description also (although it keeps throwing JS errors). However, if you try to edit the description first, it fails to initialise the editor and collapses at once.

    So we believe if you take references to all those JS errors in your browser’s JS console and contact with their support, you can find some good solution or at-least they can suggest something.

    Additionally, we have tried with noConflict() modes, since we use jQuery for our plugin, that’s a pretty much straight-forward thing to taking jQuery out of the global scope into a separate object and working on that. But that also didn’t help – believing that’s not the issue.

    We will keep this thread open for further communication, in case you want to provide more feedback from Yoast guys.

    Thanks and all the best.

    Plugin Author WPMadeasy

    (@wpmadeasy)

    Hello again, just wanted to update you that we have found an alternative solution and will be releasing an update in couple of hours. This will fix conflicting issues on both ends.

    Stay tuned.

    Plugin Author WPMadeasy

    (@wpmadeasy)

    We have just released an update (version 2.6), please remember to upgrade Shortcode Factory plugin to this latest version.

    This version particularly addresses some compatibility fixes with WP 4.9.6 and Yoast SEO 7.7.x.

    Thank you for your patience, please feel free to open a new thread for any issue in the future.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Conflict with Yoast 7.7’ is closed to new replies.