Support » Plugin: MP6 » Conflict with Wysjia plugin – error in svg-painter.js

  • I spotted a JS conflict that occurs when using MP6 in combination with the Wysija Newsletters plugin.

    Environment:
    WordPress 3.6
    Wysija Newslettters Version 2.5.5
    MP6 Version 2.0

    – Install and activate both plugins
    – Go to into menu item Wysija > Newsletters
    – Click on the first newsletter (titled “5 Minute User Guide – Draft “)
    – Select a default list and click on “Next Step”
    – On the “step 2” page, scroll to the bottom, and click the button “Send Preview”.

    Expected result:
    You should see a little modal window opening (you can see it work if you disable MP6).

    Actual result:
    Nothing happens when clicking the button. In the Javascript Console, you will see the following error message:

    Error: TypeError: $element.parent is not a function
    Source File: http://example.com/wp-content/plugins/mp6/js/svg-painter.js?ver=1377976669
    Line: 60

    This issue appeared very recently.

    http://wordpress.org/plugins/mp6/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi,

    Same problem with LayerSlider plugin v4.6.1 (latest)

    WP v3.6, MP6 v2.0

    When trying to edit a slider layer nothing works and in console I get this error> TypeError: $element.parent is not a function wp-content/plugins/mp6/js/svg-painter.js?ver=1378221399

    Funnily enough this is not happening with MP6 v1.9 which seems to work ok.

    Plugin Author Till Krüss

    (@tillkruess)

    Thanks, this has been fixed in 768784.

    Great! It’s becoming hard to work with MP6 disabled 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Conflict with Wysjia plugin – error in svg-painter.js’ is closed to new replies.