Support » Plugin: Timber » Conflict with WPML WooCommerce

  • lausianne

    (@lausianne)


    Hi,

    I have a site that uses the Hydrogen Theme with Gantry 5 and Timber 1.10.0.

    It also uses WPML and WooCommerce. Everything works well until I activate the WPML WooCommerce plugin: White screen. I tried switching to Twentynineteen, works. Then I checked all plugins and found that the site works when deactivating Timber, it just doesn’t look good …

    Maybe it would work with an older version of Timber – is there a download archive?
    Or do you have another idea how to fix this? (I’ll contact WPML support, too)

    Thank you!

    EDIT: Just found this on GitHub:
    “Important Note
    If you use WPML, please do not upgrade to 1.10.* yet. Because WPML also uses Twig, there is a conflict with loading Twig versions. They will release an update soon to keep things in sync. Until then, please use version 1.9.2”

    That explains it. Still need to know where to get an old version. Source code is on Github, but I don’t know what to do with that.

    Got it: https://wordpress.org/plugins/timber-library/advanced/
    Missing 1.9.5, but 1.9.4 works.

    • This topic was modified 4 months ago by  lausianne.
    • This topic was modified 4 months ago by  lausianne.
    • This topic was modified 4 months ago by  lausianne.
  • You must be logged in to reply to this topic.