Support » Plugin: Custom Permalinks » Conflict with WPML

  • Resolved okadots

    (@okadots)


    We are using WPML to translate pages and we are having some issues with pages that have a custom permalink.

    We have English, French and Spanish on the site.

    Original English page: https://www.internetsociety.org/events/ietf-meetings/ietf-100/
    English page w/ custom permalink: https://www.internetsociety.org/events/ietf/ietf-100/

    When I duplicate the page, it duplicates the ORIGINAL slug – greyed out – with the appropriate language parameter (ie /fr/events/ietf-meetings/ietf-100/). I edited the permalink to remove “-meetings” and when I go to the page in the browser, the url becomes /fr/fr/events/ietf/ietf-100/.

    I removed the /fr from the permalink (as WPML adds that programmatically). Now, if you are viewing the English page and go to the language switcher, you can correctly access the French and Spanish pages.

    HOWEVER, once you are on another language (FR or ES), the urls for the other translated language (not English) are incorrect and just redirect you the current language you are viewing. (https://www.internetsociety.org//fr/events/ietf/ietf-100/)

    I commented on another open ticket regarding WPML – but it was a different issue than what we are experiencing.

    WPML says that the plugin is not on their list of compatible plugins and they recommended that the authors of this plugin go here to sort out compatibility: https://wpml.org/documentation/theme-compatibility/go-global-program/

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Sami Ahmed Siddiqui

    (@sasiddiqui)

    Hi @okadots

    Sorry about the delay in the reply.

    I need one favor from you. I have an fix for this in my mind but need to check whether it works or not and for that i need to produce the issue. So, if you don’t i can make a fix on your site as you have the error and you can verify the fix as well.

    Secondly, i have contacted the WPML and maybe we would fix it out soon.

    Regards,
    Sami

    Hi @sasiddiqui.

    Thanks for getting back to me.

    I am unable to give you access to our site, but I’d be happy to test out any plugin updates and let you know if that fixes our issue! Feel free to send me a link to download a patch.

    Thanks!

    [ Please do not bump. ]

    Plugin Author Sami Ahmed Siddiqui

    (@sasiddiqui)

    Hi @okadots

    Thanks for your kindness 🙂

    I’ll ping you once the patch is ready from my side.

    Thanks,
    Sami

    hi @sasiddiqui sorry to keep bugging you on this one, but we are in a bit of a spot. i have the latest release and that doesn’t seem to solve the issue.

    thanks!

    Plugin Author Sami Ahmed Siddiqui

    (@sasiddiqui)

    Hi @okadots

    Sorry, but there is no such progress on this issue yet.

    Plugin Author Sami Ahmed Siddiqui

    (@sasiddiqui)

    Hi @okadots

    Fix has been applied in v1.3.0. Please upgrade to the latest version and check the issues now.

    Thanks,
    Sami

    @sasiddiqui – thanks for getting back to me.

    I just updated locally and the issue does not appear to be resolved. Is it possible that this fix would only be applied to newly created custom permalinks?

    Thanks!

    Plugin Author Sami Ahmed Siddiqui

    (@sasiddiqui)

    @okadots Have you tried with the newly created permalinks?

    Do you have the latest version of both plugins?

    @sasiddiqui yes i tried creating new permalinks. i also flushed the WPML caches and did some of the plugins cleanup steps.

    what version of WPML were you using? we are currently on 3.9.4 (not ready to upgrade to 4.0 quite yet – still doing testing on that)

    Plugin Author Sami Ahmed Siddiqui

    (@sasiddiqui)

    @okadots i have not tested the plugin with WPML by myself. Testing was done by the WPML Development team and they gives me the green flag. Maybe, they have tested with the latest version.

    I’ll confirm the version with the WPML Team but my personal thoughts, that they have done the testing with their latest version of the plugin.

    I suggest you to make testing with the latest version of both plugins.

    Thanks,
    Sami

    Plugin Author Sami Ahmed Siddiqui

    (@sasiddiqui)

    @okadots i have confirmed with the WPML Team that they have testes this issue with WPML version 4. So, you need to check this issue with the latest version of both plugins.

    Hope, that will be fixed the things for you.

    Thanks,
    Sami

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Conflict with WPML’ is closed to new replies.