Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    try
    seal.js, js/jquery/jquery.js, wpfront-notification-bar.js, jquery.c.js
    instead of
    seal.js, js/jquery/jquery.js,wpfront-notification-bar.js,jquery.c.js

    for more info on why the space is needed see https://wordpress.org/support/topic/2-7-0-known-issues/

    Thread Starter tidalchiro

    (@tidalchiro)

    I attempted the replacement but the notification bar still isn’t appearing. I can only get it to work by disabling Autoptomize which obviously I’d like to not do.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    OK, taking a step back;
    * does it work when “optimize JavaScript” is off?
    * does it work when “optimize JavaScript” is on but “aggregate JavaScript” is off?
    * when it does not work, what errors do you see on the browser console?

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    any news on this tidalchiro ?

    Thread Starter tidalchiro

    (@tidalchiro)

    I have not found a working solution for both plugins to function properly at the same time. I updated the exclusions list to seal.js, js/jquery/jquery.js, wpfront-notification-bar.js, jquery.c.js

    * does it work when “optimize JavaScript” is off? No
    * does it work when “optimize JavaScript” is on but “aggregate JavaScript” is off? No

    Here is the console:

    This page uses the non standard property “zoom”. Consider using calc() in the relevant property values, or using “transform” along with “transform-origin: 0 0”. tidalchiro.com
    Note: MonsterInsights does not track you as a logged-in site administrator to prevent site owners from accidentally skewing their own Google Analytics data.
    If you are testing Google Analytics code, please do so either logged out or in the private browsing/incognito mode of your web browser. tidalchiro.com:33:11
    Cookie “SIDCC” will be soon rejected because it has the “sameSite” attribute set to “none” or an invalid value, without the “secure” attribute. To know more about the “sameSite“ attribute, read https://developer.mozilla.org/docs/Web/HTTP/Headers/Set-Cookie/SameSite api.js
    ReferenceError: Backbone is not defined
    notes-common-v2.js:32:32
    ReferenceError: _ is not defined
    admin-bar-v2.js:2:38
    Request to access cookie or storage on “<URL>” was blocked because it came from a tracker and content blocking is enabled. 48
    Loading failed for the <script> with source “https://connect.facebook.net/en_US/fbevents.js”. tidalchiro.com:1:1
    JQMIGRATE: Migrate is installed, version 1.4.1 autoptimize_f625612b09ed2b6b6fa3471324f074bd.js:2:552
    downloadable font: no supported format found (font-family: "Noticons" style:normal weight:400 stretch:100 src index:1) source: (end of source list)
    Content Security Policy: Ignoring “'report-sample'” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “'report-sample'” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “'report-sample'” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “'report-sample'” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “'report-sample'” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “'report-sample'” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified
    Some cookies are misusing the recommended “sameSite“ attribute 3
    Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified
    Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified
    Thread Starter tidalchiro

    (@tidalchiro)

    Update: I have found a working configuration. I can leave the JavaScript settings on, but I have to turn off optimization for CSS.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    ah, CSS optimization? and what happens if you keep that on, but disable aggregation? of if you keep both on but exclude wpfront CSS?

    Thread Starter tidalchiro

    (@tidalchiro)

    CSS on but aggregation off does not work. Do you know what files I need to exclude for wpfront CSS? I added wpfront-notification-bar.css, options.css but it doesn’t work, even with aggregate CSS off. The only way I have found it to work is to disable CSS optimization entirely.

    • This reply was modified 4 years, 2 months ago by tidalchiro.
    Plugin Author Optimizing Matters

    (@optimizingmatters)

    try plugins/wpfront-notification-bar, if it doesn’t work try also unticking the “minify excluded CSS/ JS” option.

    Thread Starter tidalchiro

    (@tidalchiro)

    Update: I am now able to activate CSS optimization as well as aggregation by updating my “above-the-fold” CSS. Thank you for your help! I used this tool you linked: https://www.sitelocity.com/critical-path-css-generator

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    aha, above the fold CSS, good thinking! 🙂

    happy things work! feel free to leave a review of the plugin and support here! 🙂

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Conflict with WPFront’ is closed to new replies.