Support » Plugin: Yoast SEO » Conflict with WP User Avatar

  • Resolved cranewest

    (@cranewest)


    When I have Yoast SEO activated and WP User Avatar, WP User Avatar doesn’t work properly. It doesn’t matter what other plugins are active or what theme I’m using. I can’t get an error message because it times out. When a user tries to update their profile image, instead of just uploading the image, it continually creates entries in the media library with the title of the image until it times out. We ended up with like 10K entries like this from different users trying to upload their images.

    The image does seem to get uploaded, but the other entries it creates have no image, just a gray placeholder and the url for the entries are all domain.com/image-title/.

    I have tried turning off the media options in Yoast and numerous other configurations. Nothing I have tried fixes the issue.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    We understand when Yoast SEO and WP User Avatar plugins are active, there are multiple image entries created in the media library when someone uploads an avatar. Can you please confirm how the user is uploading the image? Do you have a custom profile page for that?

    On the other hand, can you please try reproducing the issue on a fresh WordPress installation with only the Yoast SEO and WP User Avatar plugins are active to see whether the issue persists for you?

    Plugin Support Priscilla Chapman

    (@priscillamc)

    Hi @cranewest,

    We’re marking this issue as resolved due to inactivity. You’re welcome to create a new issue if you need further assistance.

    I’m having the same exact problem as @cranewest

    When the Yoast SEO plugin is activated, uploading with the WP User Avatar plugin doesn’t work.

    The user is uploading the image to a url: /account/?action=profile-image

    When I disable the Yost SEO plugin, uploading with the WP User Avatar plugin works.

    • This reply was modified 4 months, 2 weeks ago by kdubyo.

    Tengo el mismo problema, estoy utilizando wp-user-avatar y al instalo el plugin Yoast SEO, al intentar cargar una imagen de perfil desde Account, me genera un loop infinito que termina agotando la memoria.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.