Support » Plugin: Tracking Code Manager » Conflict with WP Super Cache

  • Hi there,

    I noticed WP Super Cache had stopped caching pages when I installed your plugin, if I disable your plugin WP Super Cache acts as expected.

    I notice you have had a previous issue with WP Super Cache which was marked as resolved, has this crept back in?

    Regards,
    Renners

    Site details
    Version: 4.9.8
    Language: en_GB
    Permalink structure: /%category%/%postname%/
    Is this site using HTTPS?: Yes
    Can anyone register on this site?: No
    Default comment status: open
    Is this a multisite?: No
    User Count: 20
    Communication with WordPress.org: WordPress.org is reachable

    ### Installation size ###

    Uploads directory: 1.83 GB
    Themes directory: 6.57 MB
    Plugins directory: 139.63 MB
    Database size: 111.70 MB
    Whole WordPress Directory: 2.02 GB
    Total installation size: 2.13 GB

    ### Drop-ins ###

    advanced-cache.php: Advanced caching plugin.

    ### Active theme ###

    Name: Storefront

    ### Other themes (4) ###

    Storefront (storefront): Version 2.3.3 by Automattic
    Twenty Fifteen (twentyfifteen): Version 2.0 by the WordPress team
    Twenty Seventeen (twentyseventeen): Version 1.7 by the WordPress team
    Twenty Sixteen (twentysixteen): Version 1.5 by the WordPress team

    ### Server ###

    Server architecture: Windows NT 6.3 AMD64
    PHP Version: 7.2.3 (Supports 64bit values)
    PHP SAPI: cgi-fcgi
    PHP max input variables: 1000
    PHP time limit: 120
    PHP memory limit: 256M
    Max input time: 60
    Upload max filesize: 8M
    PHP post max size: 8M
    cURL Version: 7.57.0 OpenSSL/1.1.0g
    SUHOSIN installed: No
    Is the Imagick library available: No
    Htaccess rules: Custom rules have been added to your htaccess file

    ### Database ###

    Extension: mysqli
    Server version: 5.7.21-log
    Client version: mysqlnd 5.0.12-dev – 20150407 – $
    Database prefix: wp_

    ### WordPress constants ###

    ABSPATH: C:\(websites physical location)
    WP_HOME: Undefined
    WP_SITEURL: Undefined
    WP_DEBUG: Disabled
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG_DISPLAY: Enabled
    WP_DEBUG_LOG: Disabled
    SCRIPT_DEBUG: Disabled
    WP_CACHE: Enabled
    CONCATENATE_SCRIPTS: Undefined
    COMPRESS_SCRIPTS: Undefined
    COMPRESS_CSS: Undefined
    WP_LOCAL_DEV: Undefined

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author IntellyWP

    (@intellywp)

    Hi @renners,
    Thanks for choosing IntellyWP products.

    Could you please, after a plugin backup, edit the following file

    /wp-content/plugins/tracking-code-manager/includes/core.php

    and replace from line 21 to line 27

    
    function tcmp_footer() {
        global $tcmp;
        //there isn't a hook when <BODY> starts
        $tcmp->Manager->writeCodes(TCMP_POSITION_BODY);
        $tcmp->Manager->writeCodes(TCMP_POSITION_CONVERSION);
        $tcmp->Manager->writeCodes(TCMP_POSITION_FOOTER);
    }
    

    with

    
    function tcmp_footer() {
        global $tcmp;
        //there isn't a hook when <BODY> starts
        $tcmp->Manager->writeCodes(TCMP_POSITION_BODY);
        $tcmp->Manager->writeCodes(TCMP_POSITION_CONVERSION);
        $tcmp->Manager->writeCodes(TCMP_POSITION_FOOTER);
    	if(function_exists('wp_cache_set_home'))
    		unset($_POST);
    }
    

    then check again the timestamps generated by WP Super Cache?

    Thank you

    IntellyWP

    https://wordpress.org/support/topic/conflict-with-wp-super-cache-11/

    The same issue was reported 8 months ago (also over 1 year ago and so on), so come it doesn’t get fixed?

    We have the same issue with your plugin and WP Super Cache, why pasting snippets of code so users modify your plugin instead of updating it and fix the issue?

    Hi there,

    Thank you for the details, I can confirm this worked and WP Super Cache now works with both plugins active.

    #I do have the same concern as sticksu mentions above in that I now have custom code.

    I have been caught out by this before and actively work not to have custom plugins which are not controlled by myself.

    If you are not going to update your own core, can I add this amendment to our own custom plugin to achieve the same results?

    Regards,
    Renners.

    Plugin Author IntellyWP

    (@intellywp)

    Hi @sticksu and @renners,
    i’m sorry for the delay.

    Unfortunately i don’t know when this fix will be included in the next plugin update anyway i’ll forward this topic to our dev team

    Thanks for your patience

    IntellyWP

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Conflict with WP Super Cache’ is closed to new replies.