Support » Plugin: SiteGround Optimizer » Conflict with Wordfence

  • Resolved imarkinteractive

    (@imarkinteractive)


    We have been seeing sites that use this plugin have issues when the WordFence firewall is activated. Since there is a specific setup in SiteGround to use the Wordfence firewall (prepend in php.ini), after it is activated, there are the same errors on a number of sites. They are like this: https://www.screencast.com/t/iNLEJjPsCZ

    The php.ini has to be removed and the firewall turned off for the site to come back online. I have seen this on every site we touch in SiteGround since the update of the SG Optimizer.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    That’s a known issue with opcache and is not related to the plugin. Fixed it by adding to the pho.ini file:

    opcache.interned_strings_buffer = 8
    opcache.memory_consumption = 128

    Everything works fine now.

    Thread Starter imarkinteractive

    (@imarkinteractive)

    I’m still seeing this as an issue. We added that to the php.ini file and it still breaks the site.

    2019-03-21_0045

    Plugin Author Stanimir Stoyanov

    (@sstoqnov)

    SiteGround Representative

    Hi @imarkinteractive

    I’ve checked your site and I cannot find the notices you have mentioned.

    Would it be possible to provide more details how we can reproduce the issue and where do you see the errors?

    Regards,
    Stanimir

    Thread Starter imarkinteractive

    (@imarkinteractive)

    Which site are you checking?

    The site we were working on had the php.ini file removed so it wouldn’t break.

    Plugin Author Stanimir Stoyanov

    (@sstoqnov)

    SiteGround Representative

    Which one would you like me to check? 🙂

    Thread Starter imarkinteractive

    (@imarkinteractive)

    We were working on this site for a customer – https://detailedwifeorganizedlife.com

    Thread Starter imarkinteractive

    (@imarkinteractive)

    Just ran across another one with the same issue. Once I removed SG Optimizer, it works just fine.

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    This is not a regular behaviour. Please, open a ticket in your Help Desk. Our support team will assist you further. We need the propper access and agreement from the customer to debug this.

    Thread Starter imarkinteractive

    (@imarkinteractive)

    We have encountered it in at least 30 sites already and it seems to be the OPCache not clearing on your end. Each time we have to contact upper level support and they clear the OPCache. That never used to be a problem nor is it a viable solution.

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    Did you bring this to the attention of WordFence? Opcache is enabled for every PHP 7+ we have on our server and the SG Optimizer plugin has nothing to do with it. We do not manipulate Opcache from the plugin in any way.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Conflict with Wordfence’ is closed to new replies.