Support » Plugin: W3 Total Cache » Conflict with WooCommerce product visualization

  • Resolved mxmwebcome

    (@mxmwebcome)


    Hello

    As you can see in the link I provide (like in any other WooCommerce product page on the website) the “Short Description” of the product moves under the images instead of staying near them (in the right section of the page).

    I think that this happens because of a conflict with W3TC plugin: when I deactivate this plugin everything works fine.
    Is there a way to solve it?

    Thank you very much!

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,
    Can you confirm if you are using Minify setting on Auto? If so, please disable minify, purge caches and see if the issue persists.

    Yes, I’m using Minify setting on Auto. If I disable it, the issue disappear, but I’d like to continue using this functionality.
    How can I do?

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,

    You can switch to manual Minify and add JS and CSS files manually and in order. Alternatively, you can exclude WooCommerce from minify in Performance>Minify, Advanced sub-box, “Never minify the following JS files:” and “Never minify the following CSS files:”

    Thanks Marko

    I’ve understand, but I don’t know where to find JS and CSS files to exclude from Minify.

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,
    CAn you please share the screenshot and underline the issue as I am unable to find it? Is minify currently enabled?

    mxmwebcome

    (@mxmwebcome)

    Hi Marko

    When I enable Minify in AUTO mode, the error appears (see this screenshot_A): product Short Description moves under the images, instead of staying near of them.

    If I diseable Minify, all works good (see this screenshot_B).

    I can switch to manual Minify but I don’t know what JS and CSS files manually add. And I also don’t now how to exclude WooCommerce from minify in the Advanced sub-box. Is there a simple guide to follow to do this?

    Thanks in advance.
    Best regards

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,

    Sitch to manual minify in Performance>General settings. Go to Performance>Minify and in JS sub-box under JS minify settings: choose to combine only and Embed type: non-blocking using async.
    Then go to CSS sub-box and choose Embed type: Process. Save all settings. After saving got to top of the page an click on the “help” button for “Get minify hints using the help wizard. ” There you will see all suggested JS and CSS files that you can add simply by selecting the box near them. Make sure not to select any Woocomerce JS or CSS files. Be very careful with this as manual minifying can be very tricky. Add files one by one, remember which ones you’ve added and test your website after each js and CSS file you add.
    I hope this helps.

    mxmwebcome

    (@mxmwebcome)

    Thank you very much, Marko!
    Everything seems to work fine now.

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,

    Glad to know that the issue is resolved!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.