Support » Plugin: Clearfy – WordPress optimization plugin and disable ultimate tweaker » Conflict with Woocommerce Composite Products

  • Hello,

    I found out that “Webcraftic Clearfy – WordPress optimization plugin” is a conflicting plugin with Woocommerce Composite Products. I got in touch with plugin support team and they informed me that they had similar issues with other plugin – SG Optimizer. In this case, there is a Defer Render-blocking JS option that when disabled, the plugin works as expected with Composite Products. Is there a similar option in the Webcraftic Clearfy – WordPress optimization plugin?

Viewing 15 replies - 1 through 15 (of 15 total)
  • Hey @czajna

    This is Manos from SomewhereWarm — I’ve been following your conversation with the rest of the team, so I thought I’d chime in to add a few details.

    Most plugins that concatenate CSS/scripts basically try to combine all separate script/style files enqueued on each page load in a single file. This works well most of the time — in practice there are often issues when scripts are enqueued late during the course of a request. To put it simply, there are limitations in how accurately a plugin can combine script/style files with the correct order.

    Usually there is no easy fix for this — in your case one possible course of action would be to disable this “optimization” on those pages where you are experiencing issues. I’m not sure if this is possible with Clearfy, but perhaps the team here can shed some light on how you could proceed with a workaround like this.

    Cheers,
    Manos
    Head of Product
    SomewhereWarm

    Plugin Author Artem

    (@webtemyk)

    Hello, @czajna

    Try disabling JS optimization/minification completely. If the problem is resolved, you can enable optimization, but disable combining JS files

    Hello @webtemyk

    here is a different problem I encounter with a different, but similar plugin.

    When I add this product to the cart, it disappears in the cart section (https://ogarniamsie.pl/koszyk/) and alert is shown that “the product was modified and it was removed from the cart”. It happens all the time even despite the fact I don’t change this product. There is some conflict with Clearfy, because when I disable your plugin, it works well. Any ideas?

    Composite product is provided by WPC Composite Products for WooCommerce.

    Debug report: http://s000.tinyupload.com/download.php?file_id=35045468203765453034&t=3504546820376545303431606

    Clearfy settings:
    {“wbcr_clearfy_attachment_pages_redirect”:”1″,”wbcr_clearfy_change_login_errors”:”1″,”wbcr_clearfy_content_image_auto_alt”:”1″,”wbcr_clearfy_deactive_preinstall_components”:”a:1:{i:0;s:9:\”cyrlitera\”;}”,”wbcr_clearfy_disable_admin_bar”:”enable”,”wbcr_clearfy_disable_dashicons”:”0″,”wbcr_clearfy_disable_embeds”:”0″,”wbcr_clearfy_disable_emoji”:”0″,”wbcr_clearfy_disable_feed”:”1″,”wbcr_clearfy_disable_google_fonts”:”0″,”wbcr_clearfy_disable_google_maps”:”0″,”wbcr_clearfy_disable_gravatars”:”1″,”wbcr_clearfy_disable_heartbeat”:”default”,”wbcr_clearfy_disable_json_rest_api”:”0″,”wbcr_clearfy_exclude_from_disable_google_maps”:””,”wbcr_clearfy_ga_adjusted_bounce_rate”:”0″,”wbcr_clearfy_ga_anonymize_ip”:”0″,”wbcr_clearfy_ga_cache”:”0″,”wbcr_clearfy_ga_disable_display_features”:”0″,”wbcr_clearfy_ga_enqueue_order”:”0″,”wbcr_clearfy_ga_tracking_id”:””,”wbcr_clearfy_ga_track_admin”:”0″,”wbcr_clearfy_heartbeat_frequency”:”default”,”wbcr_clearfy_hide_admin_notices”:”only_selected”,”wbcr_clearfy_if_modified_since_headers”:”0″,”wbcr_clearfy_last_modified_exclude”:””,”wbcr_clearfy_lazy_load_font_awesome”:”1″,”wbcr_clearfy_lazy_load_google_fonts”:”0″,”wbcr_clearfy_protect_author_get”:”1″,”wbcr_clearfy_redirect_archives_author”:”1″,”wbcr_clearfy_redirect_archives_date”:”1″,”wbcr_clearfy_redirect_archives_tag”:”0″,”wbcr_clearfy_remove_adjacent_posts_link”:”1″,”wbcr_clearfy_remove_html_comments”:”0″,”wbcr_clearfy_remove_iframe_google_maps”:”0″,”wbcr_clearfy_remove_jquery_migrate”:”0″,”wbcr_clearfy_remove_js_version”:”1″,”wbcr_clearfy_remove_last_item_breadcrumb_yoast”:”0″,”wbcr_clearfy_remove_meta_generator”:”1″,”wbcr_clearfy_remove_recent_comments_style”:”0″,”wbcr_clearfy_remove_replytocom”:”1″,”wbcr_clearfy_remove_rsd_link”:”1″,”wbcr_clearfy_remove_shortlink_link”:”0″,”wbcr_clearfy_remove_single_pagination_duplicate”:”0″,”wbcr_clearfy_remove_style_version”:”1″,”wbcr_clearfy_remove_unneeded_widget_archives”:”1″,”wbcr_clearfy_remove_unneeded_widget_calendar”:”1″,”wbcr_clearfy_remove_unneeded_widget_categories”:”1″,”wbcr_clearfy_remove_unneeded_widget_links”:”1″,”wbcr_clearfy_remove_unneeded_widget_menu”:”0″,”wbcr_clearfy_remove_unneeded_widget_meta”:”1″,”wbcr_clearfy_remove_unneeded_widget_page”:”1″,”wbcr_clearfy_remove_unneeded_widget_recent_comments”:”0″,”wbcr_clearfy_remove_unneeded_widget_recent_posts”:”1″,”wbcr_clearfy_remove_unneeded_widget_rss”:”1″,”wbcr_clearfy_remove_unneeded_widget_search”:”0″,”wbcr_clearfy_remove_unneeded_widget_tag_cloud”:”1″,”wbcr_clearfy_remove_unneeded_widget_text”:”0″,”wbcr_clearfy_remove_unneeded_widget_twenty_eleven_ephemera”:”1″,”wbcr_clearfy_remove_version_exclude”:””,”wbcr_clearfy_remove_wlw_link”:”1″,”wbcr_clearfy_remove_xfn_link”:”0″,”wbcr_clearfy_revisions_disable”:”0″,”wbcr_clearfy_revision_limit”:”default”,”wbcr_clearfy_right_robots_txt”:”0″,”wbcr_clearfy_robots_txt_text”:”# This space intentionally left blank\r\n# If you want to learn about why our robots.txt looks like this, read this post: https:\/\/yoa.st\/robots-txt\r\nUser-Agent: *\r\nHost: https:\/\/ogarniamsie.pl\r\nSitemap: https:\/\/ogarniamsie.pl\/sitemap_index.xml”,”wbcr_clearfy_set_last_modified_headers”:”0″,”wbcr_clearfy_show_notices_in_adminbar”:”0″,”wbcr_clearfy_yoast_remove_head_comment”:”1″,”wbcr_clearfy_yoast_remove_image_from_xml_sitemap”:”0″,”wbcr_clearfy_yoast_remove_json_ld_output”:”0″,”wbcr_clearfy_yoast_remove_json_ld_search”:”0″}

    Plugin Author Artem

    (@webtemyk)

    Try resetting the Clearfy settings. Will the problem persist?

    @webtemyk : I reseted the Clearfy settings, but the problem still persist.

    Plugin Author Artem

    (@webtemyk)

    Are you using the free version of Clearfy?

    Yes, I use “Webcraftic Clearfy – WordPress optimization plugin” 1.6.8.

    @webtemyk: any updates on this issue?

    Here are some notices from debug.log, not sure if it is related:
    [03-Jul-2020 07:39:25 UTC] PHP Notice: Trying to get property ‘post_title’ of non-object in /home/mazurki/domains/ogarniamsie.pl/public_html/wp-content/plugins/clearfy_package/plugins/seo-friendly-images-premium/includes/classes/class-configurate-seo-images.php on line 522
    [03-Jul-2020 07:39:25 UTC] PHP Notice: Trying to get property ‘post_title’ of non-object in /home/mazurki/domains/ogarniamsie.pl/public_html/wp-content/plugins/clearfy_package/plugins/seo-friendly-images-premium/includes/classes/class-configurate-seo-images.php on line 525
    [03-Jul-2020 07:39:25 UTC] PHP Notice: Trying to get property ‘post_excerpt’ of non-object in /home/mazurki/domains/ogarniamsie.pl/public_html/wp-content/plugins/clearfy_package/plugins/seo-friendly-images-premium/includes/classes/class-configurate-seo-images.php on line 528
    [03-Jul-2020 07:39:25 UTC] PHP Notice: Trying to get property ‘ID’ of non-object in /home/mazurki/domains/ogarniamsie.pl/public_html/wp-content/plugins/clearfy_package/plugins/seo-friendly-images-premium/includes/classes/class-configurate-seo-images.php on line 531

    Plugin Author Artem

    (@webtemyk)

    It turns out that you are using the premium version of the plugin. I asked you.
    Try disabling the Seo Friendly Images component on the COMPONENTS tab

    Hello, it doesn’t look like a premium plugin because I see info “License activation required. A license is required to get premium plugin updates, as well as to get additional services.” and Seo friendly images is not activated (info about premium),

    This plugin was installed by external freelancer, so I don’t have a full knowledge.

    https://ibb.co/vVSCMZq
    https://ibb.co/Pc4qM7d

    Plugin Author Artem

    (@webtemyk)

    In this case, you can deactivate the premium plugin.

    I have no idea what your problem is

    I don’t really understand. As I sent you screenshots these plugins are free plugins, aren’t they?

    Plugin Author Artem

    (@webtemyk)

    Clearfy Package is a premium plugin. If you don’t have a license key, you can deactivate and delete this plugin

    Ok, I see. I deleted this plugin, but unfortunately it didn’t fix the issue

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.