Support » Plugin: Email Encoder - Protect Email Addresses and Phone Numbers » Conflict with Wishlist Member

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter Travis Pflanz


    I have also directed the Wishlist Member support team to this thread to connect you.

    Plugin Author Ironikus


    Hey @tpflanz – thank you a lot for your message, as well as for using our plugin.
    From what I can see within your screenshot, it looks like there are emails directly included within the Javascript of your website. This might be (but not necessarily) caused by Wishlist Member.

    Since it looks like the added script does not allow any CDATA for the script, HTML entities can’t be encoded from there, which is causing the issue. To read more about that. please take a look at the definition here:

    What I suggest you try: Our plugin offers a feature to exclude script tags from being encoded. To test that, please head over to your WordPress dashboard -> Email Encoder and activate the Advanced settings.
    Once you see the further settings, you will find a setting within the Protect… group called no script tags. Please check that box and save the settings.

    If the issue still exists afterward, feel free to let me know and we will further debug it.
    Thank you already very much.

    Thread Starter Travis Pflanz


    I have checked no script tags ( and get the same result on the frontend –

    Hello guys,

    Ronald here, one of the developers from WishList Products.

    WishList Member do indeed add an email address to a javascript code which we use on our Stripe Profile shortcode. (The shortcode only works for logged in users). I believe this email address is the one being filtered by the “Email Encoder” plugin which was causing the code to be displayed on the page.

    I went ahead and checked more on the Email Encoder plugin’s settings and a potential solution to the issue would be to exclude the page that has the Profile shortcode from being scanned by Email Encoder.

    The plugin has an “Advance Settings” option.


    Please try this.

    1. Enable the “Advance Settings” option and then hit save.

    2. Once that’s been enabled a new set of settings will appear. Head to the “Exclude post id’s from protection” section and add the post/page ID of the page that has the Stripe Profile Shortcode.


    I believe this should resolve the conflict you’re having without changing any other settings on the “Email Encoder” plugin.

    As for the email address on the Stripe Profile page being exposed, the Stripe profile page only works for logged in users so spam bots won’t be able to see the email address added in the Javascript code.

    Additionally you can apply WishList Member Protection to the page that has the Stripe Profile shortcode so only logged in users can view the page.

    We hope this helps.

    Thread Starter Travis Pflanz


    Thanks, Ronald.

    I tested both methods you mentioned and they both worked independently of each other.

    • Excluding the post ID for the profile page in Email Encoder advanced settings worked
    • Using Divi – setting the module to display only to Wishlist members worked

    Plugin Author Ironikus


    Hey @ronald926 – Thank you for jumping in, as well as for providing the additional information.

    @travis – since the emails added within a script tag, checking the box for “no script tags” should have solved the issue as well.
    Since it hasn’t, I could think of two possible issues:
    1. Caching left the site in the previous state (either server-sided like varnish or via WordPress).

    2. The script tags could not be found since the DOM document couldn’t be built properly within PHP. To make sure this isn’t the case, you could check the debug.log files of your server if you see there any notification from our plugin.

    In case you do not need any further help after that, feel free to mark the topic as resolved. 🙂
    Have a great day!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Conflict with Wishlist Member’ is closed to new replies.