Support » Plugin: Disable Blogging in WordPress » Conflict with Visual Composer

  • Resolved nadavss

    (@nadavss)


    Hi Fact Maven,

    We activated your plugin about a month ago and it does exactly what you say it does and what we wanted.

    There’s just one problem: since upgrading to the latest version of Visual Composer, your plugin now interferes with it in an ever so slight but crucial manner: when Disable Blogging is activated, the row and column tags disappear from front-end editing on VC, which makes it extremely difficult to use VC properly (I wish I could show you a screenshot of what I’m talking about, but WordPress doesn’t appear to offer this).

    This was the response I got from VC’s support team regarding the conflict:

    “Unfortunately, the disable blogging is a third party plugin and we are not aware of the code used in it. We checked it further and it looks like some CSS and Js code from the plugin is altering the visual composer causing this issue.”

    Do you have any idea what could be causing the issue in your plugin’s code? I’ve disabled your plugin temporarily as we absolutely must have the full functionality of Visual Composer. However, once we go live, we need both their plugin and your plugin activated.

    Thanks.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Fact Maven

    (@factmaven)

    In order for us to help narrow down and fix this issue, please verify the following for us.

    …since upgrading to the latest version of Visual Composer…

    What version are you currently running?

    …the row and column tags disappear from front-end editing on VC, which makes it extremely difficult to use VC properly (I wish I could show you a screenshot of what I’m talking about, but WordPress doesn’t appear to offer this)…

    WordPress doesn’t offer screenshots, but you can take one from your computer. Please look online on how to take a screenshot (PC or Mac). Show us what VC looks like before enabling Disable Blogging, then another one with the plugin activated. Then you can upload the screenshots on an image sharing site such as Imgur and share the links here.

    Do you have any idea what could be causing the issue in your plugin’s code?

    Based off of VC’s comment, we have an idea on where to start investigating. Addressing the points above will help us narrow it down.

    • This reply was modified 2 years, 11 months ago by Fact Maven.

    Thanks for your quick response.

    We’re running Version 5.0.1 of Visual Composer.

    This is how it should look:

    View post on imgur.com

    What was happening was that the circled bits in the screenshot were disappearing. We could still click on them, but we were doing so blind, i.e. we could mistakenly hit trash instead of edit.

    I just reactivated Disable Plugin to take a photo of the problem, and would you believe it – everything was working as it should. It’s really strange, as yesterday when I was testing this, it was a clear-cut case of: activate your plugin, the conflict occurs; deactivate it, problem solved.

    So I guess we can consider this temporarily solved and I’ll touch base again if the problem re-occurs. Unless you have an inkling as to what the issue could be and we could give it a permanent fix?

    Cheers.

    Correction: I meant that we reactivated Disable Blogging, not Disable Plugin, of course…

    Plugin Author Fact Maven

    (@factmaven)

    Interesting. Did you recently change your settings in Disable Blogging?

    We also use VC with the latest version (5.0.1) on websites that we develop and haven’t noticed a conflict with it so far. There may be another plugin that is causing the conflict. Please check by disabling all of your plugins and activate each plugin one-by-one until you see the VC options missing again.

    I tested yesterday by disabling all plugins and activating one by one, and this revealed Disable Blogging to be causing the conflict. I tried enabling and disabling a few of the settings on Disable Blogging to see if it would fix this, but that didn’t help.

    I know it sounds strange, but it truly was causing a conflict yesterday, and since re-activating today – it’s working fine. Are there any possible explanations for this?

    As I said, we want Disable Blogging as it does exactly what we need it to, so I’m happy to continue using as is, and will certainly let you know right away if this bizarre conflict somehow re-appears.

    Plugin Author Fact Maven

    (@factmaven)

    I know it sounds strange, but it truly was causing a conflict yesterday, and since re-activating today – it’s working fine. Are there any possible explanations for this?

    Not sure since we haven’t been able to reproduce it on our end. To take a guess, it could be cache related.

    Since you are no longer experiencing any issues. I’ll mark this ticket as resolved until you experience this issue again.

    No problem.
    Thanks again for your support on this.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Conflict with Visual Composer’ is closed to new replies.