Support » Theme: Rife Free » Conflict with translate plugin

  • Resolved oguido

    (@oguido)


    Hello, I’m trying to use the ggl language translator plugin together with your theme, but I realized that if that plugin is activated, the sticky header feature of your theme stops working (in mobile view). I’ve disabled the “floating widget” that the plugin comes with but it still creates the conflict. I’ve already messaged them but my question to you is, do you have any idea how could I workaround this issue if I still would like to use the plugin and maintain the sticky header?
    Thank you very much

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter oguido

    (@oguido)

    I’ve contacted the makers of the translate plugin and here’s their answer:
    “…There is a conflict with the scroll event listener. When I block https://translate.googleapis.com/element/TE_20201130_00/e/js/element/element_main.js file from loading in my browser console, it works fine. With it, your top menu does not adjust itself when I scroll down.

    As this is an external script, we will not be able to adjust it and your menu needs to be adjusted instead, it would be better if you talk to your menu provider.”

    So according to them, it’s something that could be solved on the side of the sticky menu code…
    Can you help me?

    Thank you very much

    Theme Author apollo13themes

    (@apollo13themes)

    Hey @oguido πŸ™‚

    Could you show me on a live website and if possible a screenshot what is the issue?

    With kind regards.
    Air.

    Thread Starter oguido

    (@oguido)

    hey,
    yes this is the website
    and without the translate plugin (deactivated) it looks like this when the overriding settings sticky menu appears
    with the translate plugin looks like this
    I left the conflicting plugin on so you can check it
    thank you!

    Theme Author apollo13themes

    (@apollo13themes)

    Hey πŸ™‚

    I can not check your website, as it is under the “coming soon” mode.

    Thanks for the screenshots!

    Still, I will need to see the website live, to check if something is happening in the styles, or in the source code.

    With kind regards.
    Air.

    Thread Starter oguido

    (@oguido)

    oh! I’m so sorry, I forgot. Just before yesterday the client asked me to put it like that. It’s live now πŸ‘ πŸ™
    THX!

    Theme Author apollo13themes

    (@apollo13themes)

    OK, I see what is going on.

    Some of your plugin is adding an inline style to the html tag that breaks scroll on the page – look at the right side of the page, to see white margin, on firefox for example.

    To be precise, scroll “Action” is moved to a different element, instead of having it in the window.

    Because of that, the theme can not detect that the page is scrolling, and activate the sticky header and other actions connected to window scrolling.

    To be honest I don’t know, why plugins that add small features, try to act on elements like html that are clearly theme territory πŸ™‚

    What you can do, a dirty way, is adding custom CSS like that:

    html {
        height: auto !important;
    }

    With kind regards.
    Air.

    Thread Starter oguido

    (@oguido)

    That’s great, than you so much for your effort! And yeah, I do agree with you over the theme’s “territory” πŸ€·β€β™‚οΈ
    thanks!! great work on your theme, gave 5 stars πŸ™Œ

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.