Support » Plugin: Modal Dialog » Conflict with the Mobile_Detect.php library

  • Resolved John

    (@johnmcole)


    Hi Yannick,

    I recently tried to activate the latest version of the Scroll KIt WP plugin (http://wordpress.org/plugins/scrollkit/) and got a fatal error on activation.

    This is due to both Modal Dialog and Scroll Kit declaring the same class: Mobile_Detect

    I expect that this problem may continue to be more common as other plugins use the Mobile_Detect.php library. Is this something that you can address in the next version?

    thanks,
    John

    http://wordpress.org/plugins/modal-dialog/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Yannick Lefebvre

    (@jackdewey)

    Hi John, I just renamed the class to avoid conflicts with other plugins using the same library. Please upgrade to the latest and confirm that it works correctly. Once validated, mark the issue as resolved.

    Thanks for the great support Yannick! It looks like the issue is resolved.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Conflict with the Mobile_Detect.php library’ is closed to new replies.