Support » Plugin: Complianz | GDPR Cookie Consent » Conflict with the “Advanced noCaptcha & invisible Captcha” plugin

  • Resolved mengeco

    (@mengeco)


    Hello,

    Your plugin is in conflict with the “Advanced noCaptcha & invisible Captcha” plugin

    I have done a lot of testing and when you send a simple form, you receive an error message and the form remains blocked :

    “One or more fields contain an error, please check and try again.”
    https://snipboard.io/3XUjDR.jpg

    Since all my sites work with “Advanced noCaptcha & invisible Captcha” (excellent plugin), I can not offer “Complianz | GDPR Cookie Consent” to my clients.

    Regards

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hi @mengeco,

    The Recaptcha feature from Google is blocked by Complianz until the user has given consent. For more information on privacy issues raised by using Recaptcha see also this article:
    https://complianz.io/google-recaptcha-and-the-gdpr-a-possible-conflict/

    I’ve just tested with V3 on a sandbox. Posting a comment worked after I had accepted cookies, which is the correct behaviour. Before accepting cookies the plugin throws an warning. You could replace the message with something like “accept cookies to submit the form” to inform users what is happening.

    If it doesn’t work on your site after the user accepts cookies, Recaptcha is not activated correctly by Complianz. If this is the case I’ll need some more info to reproduce it and fix the problem, especially the Recaptcha settings.

    If you don’t want Complianz to block Recaptcha, you can disable the cookie blocker in complianz/settings.

    Thank you for your reply.
    How to disable captcha blocking, I do not see the setting in the settings

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    It is the option “disable cookie blocker”. If you check this option, third party services won’t get blocked anymore.

    Thanks but from “Settings” or “Banner cookies”, I do not see this option

    Plugin Support Leon

    (@leonwimmenhoeve)

    Hi @mengeco,

    You should see this option via the ‘Settings’ menu as the sixth option, named ‘disable cookie blocker’

    ok, thanks, it’s work

    Hello,

    If I define ‘disable cookie blocker, it’s ok

    But if I activate it, tested on my site, when I validate the cookies banner, my form Contact Form 7 does not work.

    thanks
    Pierre

    Plugin Support Aert Hulsebos

    (@aahulsebos)

    Hi Pierre,

    Are you using the reCAPTCHA add-on from CF7? You can disable reCAPTCHA as a blocked service, under Complianz > Integrations.

    Could you post your URL so we can have a look?

    regards Aert

    THanks,

    I use the plugin “ReCaptcha Invisible” but not the CF7 integrate tool.
    Sorry but I can not make the site URL publicly accessible

    Plugin Support Aert Hulsebos

    (@aahulsebos)

    Hi @mengeco,

    Let me check. regards Aert

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.