Support » Plugin: Autoptimize » Conflict with SyntaxHighlighter Evolved in Gutenberg

  • voneff

    (@voneff)


    Hi Frank and Autoptimize team,

    thank you for your work on this plugin.

    I’ve run into a plugin conflict. When I’m running Autoptimize together with the plugin “SyntaxHighlighter Evolved” on a fairly basic WP 5.0.3 installation, blog entries with the Gutenberg block from SyntaxHighlighter Evolved won’t load and freeze the browser.

    I’m gathering from older support requests that the plugin (and other Syntax highlighter plugins) have caused trouble in the past and were excluded from optimization by you in the plugin source code.

    I also tried adding wp-content/plugins/syntaxhighlighter/ to the “Exclude scripts from Autoptimize:” section but this did not help.

    I narrowed it down to these two plugins. When I deactivate Autoptimize, SyntaxHighlighter works just fine.

    Could I ask you for a suggestion on what could be the issue here?

    Cheers
    Alex

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    I use SyntaxHighlighter as well and have had this issue on my own blog now and again, and the only solution I found was settings HighLighter version to 2.x iso 3.x.

    hope this helps,
    frank

    Thread Starter voneff

    (@voneff)

    Hi Frank,

    thanks for the info.

    I’ll look for a different plugin then – and will alert the plugin author that his plugin is causing problems.

    Cheers
    Alex

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    you’re welcome.

    to be clear; I did not switch to another plugin, the syntaxhighlighter plugin I use allows me to change the highlighter JS version used on the settings page.

    but there’s something weird with plugins that spit out formatted code; I use code snippets on /wp-admin (so non-autoptimized) and that freezes on me (and others) as well now and again. no idea why either .. :-/

    Alex Mills

    (@viper007bond)

    Yeah, the highlighting library my plugin uses doesn’t like being further minified (it already is on its own).

    Excluding it from both minification and concatenation has fixed it for other users:

    https://github.com/Viper007Bond/syntaxhighlighter/pull/84

    Hi Frank,

    I just hit this issue too. I’m just wondering why adding it to the exclude list doesn’t seem to actually exclude (at least from my testing). I’ve tried variations of ‘shCore.js, shBrushXml.js, etc’ and then using paths like ‘/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shCore.js, etc’. It seems like they still always get processed by Autoptimize. I can see if I add things like ‘js/jquery/jquery.js’ to be excluded then it does get properly ignored. Why not these other files?

    Thanks,
    Matt

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    OK, that helps @mattgoldspink, what is likely happening; as of AO 2.4 excluded JS (and CSS) which is not minified (based on filename ending in min.js or min.css) is minified.

    You can disable that functionality with this line of code, can you try if that fixes the syntaxhighther issue for you;

    
    add_filter('autoptimize_filter_js_minify_excluded','__return_false');

    @viper007bond would you consider changing filenames to indicate they’re minified already (so ending in .min.js or -min.js, same goes for CSS)?

    frank

    @viper007bond would you consider changing filenames to indicate they’re minified already (so ending in .min.js or -min.js, same goes for CSS)?

    As it’s a third-party library and not one I wrote myself, I’d rather not change it. Sorry. 🙁

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    Too bad, in that case the only workaround is to use that filter mentioned in https://wordpress.org/support/topic/conflict-with-syntaxhighlighter-evolved-in-gutenberg/#post-11108169

    fyi; AO 2.5 will have a filter which will allow to let AO know what files have to be considered minified, so at that point one could hook into that to avoid minification of those files if/ when excluded.

    Thanks. Adding the filter to avoid minifying excluded files fixes it for me.

    It seems like that should be the default behavior – if a file is excluded from optimization, it seems like the expected behavior would be that it wouldn’t be minified.

    • This reply was modified 2 years, 10 months ago by ideawrights.
    Plugin Author Optimizing Matters

    (@optimizingmatters)

    well, AO25 has this as an option to enable/ disable, so it’ll at least be more straightforward 🙂

    Hi Frank,

    I’m just confirming that this new option works great for Syntax Highlighter Evolved and is much easier to maintain than a filter in the theme’s functions.php that excludes specific pages.

    Thanks for a great addition to AO25!

    BTW, I also added info about this on my page about my Syntax Highlighter Evolved page for my Liquid Brush, with shout outs to Frank and Alex for their help and input.
    https://raisedbyturtles.org/liquid-syntax-highlighter-wordpress#minification

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Conflict with SyntaxHighlighter Evolved in Gutenberg’ is closed to new replies.