WordPress.org

Support

Support » Plugins and Hacks » SEO Ultimate » Conflict with Stripe plugin for WooCommerce

Conflict with Stripe plugin for WooCommerce

  • My Store (bluedotrobot.com/store) suddenly stopped taking credit card payments and it was tough to figure out why. The plugin developer was seeing the error message (“trouble connecting to payment gateway”) as an issue that would happen at the host level with the server not allowing the call. Meanwhile, after many hours on the phone with the host, they found nothing out of place and said it appeared the the plugin was trying to use http rather than https… No one knew the deal. After a lot of trial and error and disabling everything and reenabling one at a time (taking careful notes all the while), it turns out everything is working great until I turn on SEO Ultimate. The error the customer sees then in the ‘trouble connecting to payment gateway’ and the true php error is this: WP_Error Object ( [errors] => Array ( [http_request_failed] => Array ( [0] => Couldn’t resolve host ‘api.stripe.com’ ) ) [error_data] => Array ( ) )

    I don’t know why there’s a conflict but i want to let you know about it.

    WooCommerce Version 2.0.13
    WooCommerce Stripe Gateway Version 1.5.13
    WP Version 3.6

    http://wordpress.org/plugins/seo-ultimate/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Mische you beat me to it!

    Devs, the WooThemes ticket # is: 83077

    I think the problem is that the stripe plugin is very persistent in ensuring the Force SSL option is checked, this can cause conflicts with a few plugins. I prefer to use the HTTPS plugin to force https rather than the checkbox in woocommerce, but the stripe plugin dosen’t actually check for https, just that the box is checked. Poor implementation IMHO.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Conflict with Stripe plugin for WooCommerce’ is closed to new replies.
Skip to toolbar