Support » Plugin: Internal Link Juicer: SEO Auto Linker for WordPress » Conflict with some plugins or themes

  • Resolved dimalifragis

    (@dimalifragis)


    When using my theme’s customizer, saving goes wrong (but saves). It displayed an error “Looks like something’s gone wrong. Wait a couple seconds, and then try again”.

    Disabling all plugins, i found yours and two others conflicting. I fixed it removing PAGES post types from your settings.

    Now there is no error but it takes the Customiser of the theme to save/publish a long time.

    Disabling your plugin, published immediately.

    You may want to review all that.

    Thanks !

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Internal Links

    (@internallinkjuicer)

    Hello @dimalifragis

    we cannot support other 3rd party plugins, of course.

    But your question is related to the topic we already have discussed here: https://wordpress.org/support/topic/performance-limitations-2/ – if you have a lot posts and a lot of configured keywords, please consider to upgrade to our Pro version and switch the index mode.

    Sure you can’t support other plugins.

    When saving (publising) via a theme’s customizer, are your plugin interfering? Because the delay tells me it does. And if so, why ?

    That is the problem of delay.

    As for the other problem, i’m not a programmer, so i’ll pass. Maybe it is your fault, maybe the other plugins.

    Plugin Author Internal Links

    (@internallinkjuicer)

    The problem is, that you’ve configured too much keywords for too much posts which should get handled by your webserver (caused by using the “automatic” index generation mode, which is default at basic version).

    When building the index, that costs calculation time. So, every time a change is made, that affects the index (editing ILJ settings, editing post content or configuring keywords for posts) the index needs to be rebuilt right after your action – lot stuff to calculate leads to additional loading time (in the backend, the frontend stays fast).

    So if you change the index mode to the cronjob mode that additional calculation time will be completely over (because of calculation is done in a native way by the server).

    But i don’t change/add content. I’m changing a color in theme’s customizer. What index has to do with it ?

    Hi,
    In the settings in Whitelist of post types, that should be used for linking when I select Product it is showing this error

    Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 102400 bytes) in /home/public_html/wp-includes/functions.php on line 4339

    What is this error? How to resolve the issue?

    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.