Support » Plugin: Enhanced Media Library » Conflict with Shortcode UI Plugin

  • Resolved kshaner

    (@kshaner)



    Hi,

    There is a javascript error that prevents opening the shortcode ui plugin (https://wordpress.org/plugins/shortcode-ui/) window from opening or editing a shortcode. I’ve verified this with an empty version of wordpress and a basic shortcode ui example.

    The error is ‘TypeError: n is undefined’.

    It first appeared in version 2.4.0 as 2.3.6 does throw the error. It appears in the console after clicking the ‘Add Post Element’ button and when clicking “Add Media -> Insert Post Element.

    Kurtis

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author webbistro

    (@webbistro)

    Hi Kurtis,

    Thank you for informing me! It will be fixed in the next version 2.4.2

    Best,
    -Nadia

    Plugin Author webbistro

    (@webbistro)

    Hi Kurtis,

    Fixed in v2.4.2

    Best,
    -Nadia

    Hi,

    Unfortunately the bug persists. Here’s a screenshot of the call stack for reference: https://dl.dropboxusercontent.com/u/8759774/Screen%20Shot%202017-01-20%20at%2012.20.08.png .

    It occurs when clicking the Add Post Element button or when attempting to edit a current shortcode. If I edit the eml-media-views file and console the arguments, it appears that console.fixLayout is undefined at line 1079 which then is passed as the function argument to underscore bind.

    We also have ACF installed. If I deactivate ACF, the error is not thrown.

    Kurtis

    Plugin Author webbistro

    (@webbistro)

    Hi Kurtis,

    Please replace line 1078 with

    
    if ( typeof acf !== 'undefined' && $('.acf-expand-details').length ) {
    

    We will add this to the next release. Thank you for your help!

    Best,
    -Nadia

    • This reply was modified 1 year, 7 months ago by  webbistro.

    Thanks Nadia, this seems to do the trick. Ship it! 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Conflict with Shortcode UI Plugin’ is closed to new replies.