WordPress.org

Forums

Exec-PHP
[resolved] Conflict with RSS Feed (3 posts)

  1. askolo
    Member
    Posted 1 year ago #

    Hi,
    Exec php is a great plugin, however, I struggle to make my RSS feed work... (http://www.weekenda2.fr/feed). I modified the RSS feed by including "pages" as I use this format quite a lot by adding the following code to my template:

    // Add Pages to RSS Feeds
    function myfeed_request($qv) {
        if (isset($qv['feed']) && !isset($qv['post_type']))
    
            $qv['post_type'] = array('post', 'page');
        return $qv;
    }
    add_filter('request', 'myfeed_request');

    When trying to check the feed with http://validator.w3.org/feed/check.cgi?url=http%3A%2F%2Fwww.weekenda2.fr%2Ffeed

    I get an error message which is: line 43, column 0: XML parsing error: <unknown>:43:1: unclosed CDATA section

    Does someone has an Idea? I precise that I deactivated all plugins and as I reactivated them one by one, realized that this conflict was caused by Exec php plugin.

    Any help will MORE than appreciated!! Thanks a lot :)

    http://wordpress.org/plugins/exec-php/

  2. askolo
    Member
    Posted 1 year ago #

    This might help too...
    I made several tests, modifications... I published a new "page" and the issue is always in the feed loop.
    The first "post" is ok, I get:

    <item>
    <title>Édimbourg</title>
    <link>http://www.weekenda2.fr/edimbourg</link>
    <comments>http://www.weekenda2.fr/edimbourg#comments</comments>
    <pubDate>Sun, 18 Aug 2013 08:35:58 +0000</pubDate>
    <dc:creator>anthony</dc:creator>
    <guid isPermaLink="false">http://www.weekenda2.fr/?page_id=2297</guid>
    <description><![CDATA[Visitez l’une des villes principales et des plus jolies villes d’Ecosse grâce à une sélection d’offres que vous trouverez ci-dessous et tombez amoureux de cette ville fière de ses traditions et ancrée dans l’histoire.
    
    
    The Royal ...]]></description>
    <wfw:commentRss>http://www.weekenda2.fr/edimbourg/feed</wfw:commentRss>
    <slash:comments>0</slash:comments>
    </item>

    but every time, when parsing the second <item> I get the "unclosed CDATA section".

    Is there a hook I could use in my function.php file to solve that?
    thks

  3. askolo
    Member
    Posted 1 year ago #

    Probleme resolved: the bug was caused by an include and not an include_once messing up the xml feed whilst working fine on the html part...

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Exec-PHP
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic