Support » Plugin: If Menu - Visibility control for Menu Items » Conflict with RCP: RCP_Levels::get_levels is deprecated

  • Hi,

    I have detected a conflict of your plugin with the Restrict Content Pro plugin.

    RCP_Levels::get_levels has been deprecated since version 3.4. Use rcp_get_membership_levels instead.

    I solved it by changing lines 418 and 419 of /src/conditions-multiple-options.php to the following line.

    $levels = rcp_get_membership_levels( array( ‘status’ => ‘active’, ‘number’ => 100 ) );

    I hope you find it useful and correct it in the next update.

    Regards

  • You must be logged in to reply to this topic.