Support » Plugin: Harrys Gravatar Cache » conflict with postman

  • Resolved alexlii

    (@alexlii)


    I found it conflict with a popular plugin of postmen with the reason WP_mail, would you please have a check.

    Alex

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Harry Milatz

    (@harry-milatz)

    Hi Alex,

    is this the plugin https://wordpress.org/plugins/postman-smtp/ with the conflict? I see that this plugin is tested up to WordPress 4.4.10
    Can you give me more details about the conflict?

    Best regards,
    Harry

    Thread Starter alexlii

    (@alexlii)

    yes, just that plugin, once Harrys Gravatar Cache was activated, the following error message will be shown up at backend, please check the screenshot:
    http://prntscr.com/gaficj

    WordPress MU 4.6.5, both of postman and Harrys Gravatar Cache were activated in subsite. Also, Harrys Gravatar Cache can not be deactivated if wordpress is under english version, but it can be deactivated in Chinese version.

    Alex

    • This reply was modified 3 years, 9 months ago by alexlii.
    • This reply was modified 3 years, 9 months ago by alexlii.
    Plugin Author Harry Milatz

    (@harry-milatz)

    Ok, so my plugin is not using “wp_mail”. Maybe there is another conflict.

    Could you enable debugging and post the message from your debug.log?

    Can my plugin be deactivated in the english version if postman is not activated?

    Have you checked this with a standard template/theme?

    Thread Starter alexlii

    (@alexlii)

    I activated twenty-sixteen theme, and it can be deactivated in wordpress english version this time, but the error message same once it was activated, please check the screenshot:
    http://prntscr.com/gai18t

    I am not good at debug, the following message for your reference:

    2017/08/19 14:44:05 [error] 4601#4601: *201512 connect() failed (111: Connection refused) while connecting to upstream, client: 222.129.104.124, server: oursite.com, request: “GET /wp-admin/plugins.php?s=+Harrys+Gravatar+Cache HTTP/1.1”, upstream: “fastcgi://127.0.0.1:8000”, host: “subsite.oursite.com”, referrer: “http://subsite.oursite.com/wp-admin/plugins.php?ip-geo-block-auth-nonce=02f7e2ec3e”

    Alex

    Plugin Author Harry Milatz

    (@harry-milatz)

    Ok the issue with being deactivated in WP english could be caused by the other theme.

    Is there any error message on the setting page from my plugin?

    Are you running on NGINX?
    ‘Connection refused’ means that backend does not listen to the port 8000 or its queue is filled up. This problem is related to the backend from NGINX itself.
    Maybe you could ask your hoster about this.
    Something like this

    server {
        listen 127.0.0.1;
        server_name localhost;
    
        error_log /var/log/nginx/localhost.error_log info;
    
        root /var/www/localhost/htdocs;
    
        location ~ \.php$ {
            fastcgi_pass 127.0.0.1:8000;
            include /etc/nginx/conf.d/*.conf;
            include /etc/nginx/sites-enabled/*;
    
            fastcgi_intercept_errors        on;
            error_page 404 /error/404.php;
        }
    }

    adding to the to the nginx.conf in the http context should do the job.

    Or try to disable the ip-geo-block.

    I don’t know if the conflict is gone when postman is deactivated, maybe this version is too old for NGINX with this configuration.

    Thread Starter alexlii

    (@alexlii)

    Yes, we run HHvm+ngix+Redis

    I did deactivated ip-geo-block, but the error messages is same.

    I will ask expert to check, thanks a lot.

    Alex

    • This reply was modified 3 years, 9 months ago by alexlii.

    @harry: I have the same error and could track it down to the pluggable.php you are requiring once in your code!

    Is this include needed in order to make your plugin work?

    Plugin Author Harry Milatz

    (@harry-milatz)

    Hi Kai,

    is your error with my plugin and the postman-plugin?

    Have you any debug.log information for me to get more information for the error?

    The pluggable.php is need to install/activate the plugin and have access to some functions from WP. The pluggable.php is a WP Core-file.

    If your error is something like “PHP Warning: Cannot modify header information – headers already sent by (output started at …) in ../../wp-includes/pluggable.php on line…” you should take a look here:
    http://www.johnbhartley.com/2014/wordpress-error-modify-header-information-pluggable-php/
    http://www.wpbeginner.com/wp-tutorials/how-to-fix-pluggable-php-file-errors-in-wordpress/

    In most cases this error is caused by a theme or another “old” plugin.

    If it is another error, please give me some more information

    Best regards,
    Harry

    Hi Harry,

    thank you for you reply there is a message on top of the page:

    “Postman: wp_mail wurde von einem anderen Plugin oder Theme ausgewählt, weshalb Sie Postman nicht nutzen können, bis dieser Konflikt gelöst ist.”

    Plugin Author Harry Milatz

    (@harry-milatz)

    Hi Kai,

    as i wrote in my first post here on this issue, the postman-plugin is tested up to WordPress 4.4.10 and seems that is removed from the plugin directory on https://wordpress.org/plugins/postman-smtp/

    Maybe i could help if your debug.log has captured the error-message.
    Please post it here.

    But maybe the postman plugin is to old for WordPress now. ‘wp_mail’ is not used by my plugin. So i guess the error is on postman itself or another “old” plugin or theme or “new” plugin or theme which is using ‘wp_mail’ and postman could not get access anymore.

    Best regards,
    Harry

    OK I replaced Postman with WP Easy SMTP and it works like charm 🙂
    Thank you!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘conflict with postman’ is closed to new replies.