Support » Plugin: Slide Anything - Responsive Content / HTML Slider and Carousel » Conflict with other versions of jQuery

  • I have to load the latest version of jQuery from googleapis.com (or a local version) in order to use Zurb’s Foundation, but if I do that, then Slide Anything doesn’t display. The style is set to “display: none;” when I load my own version from the functions.php file.

    For example:

    wp_deregister_script(‘jquery’);
    wp_register_script(‘jquery’, “http://ajax.googleapis.com/ajax/libs/jquery/3.1.1/jquery.min.js”, ”,”, true);

    • This topic was modified 1 year, 11 months ago by  Treebeard.
Viewing 2 replies - 1 through 2 (of 2 total)
  • ok, I guess don’t use google, I think I got it working if I just use the version that comes with Foundation (I have no idea why I can’t just use wordpress’ version of jquery, it never worked with foundation for some reason).

    All good. I do LOVE this plugin

    PS: It would be great if there was either an option to deactivate the jquery that’s registered from within the plugin, or if there was some documentation on how to do deregister it from the functions.php file.

    • This reply was modified 1 year, 11 months ago by  Treebeard.
    Plugin Author simonpedge

    (@simonpedge)

    Slide Anything does use the version of jQuery that comes bundled with WordPress.

    Originally when I tried to submit this plugin into the WordPress.org repository, my submission was rejected by WordPress.org, and I was told I must rewrite the plugin to use the jQuery that comes bundled within WP, which I did.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Conflict with other versions of jQuery’ is closed to new replies.