Support » Plugin: If Menu - Visibility control for Menu Items » Conflict with other plugin after WordPress update

  • Resolved mh

    (@mmgh)


    After the last WordPress update I got following message: “If Menu detected a conflict with another plugin or theme (Menu_Item_Custom_Fields_Walker) and may not work as expected.”
    I believe this other plugin is Menu Icons by ThemeIsle.
    There is indeed a malfunction. Is the only remedy to remove the other plug-in?

Viewing 6 replies - 1 through 6 (of 6 total)
  • nmble

    (@nmble)

    I have that very same issue.

    Plugin Author Andrei

    (@andreiigna)

    Hi,

    Yes indeed this is caused by the latest WordPress update, that changes functionality for menu items. All plugins and themes need to adapt to this, and If Menu has a fix in latest update.

    Can you check if you’re using If Menu v0.16 on your site? If using this and visibility rules are not appearing for menu items, it means another plugin or theme is not updated for the changes in WordPress, and breaks the functionality for this plugin too.

    I’m looking into this, making it work somehow, and update here with more details later.

    Cheers

    mh

    (@mmgh)

    Hi,

    Yes, I am using If Menu v0.16 and after removing any plugin with issues, all seems well.

    Plugin Author Andrei

    (@andreiigna)

    After checking in more detail, saw that Menu Items plugin is causing this conflict.

    All plugin/theme developers received a notification to ready their code for this change, but looks like Menu Icons plugin wasn’t updated recently.
    Screenshot-2020-04-11-at-13-44-17

    I left a comment here https://github.com/Codeinwp/wp-menu-icons/issues/163 and hopefully the developers will see it and update the plugin for compatibility with WP 5.4

    If Menu is also update to display more descriptive warning messages, depending on the severity of conflict. This is the only thing we can on from this plugin.

    Cheers

    Hi Guys
    I have the same problem with a plugin that we use for our membership system (indeed ultimate memebership pro plugin)
    If Menu detected a conflict with another plugin or theme (IndeedWalkerMenu_IHC) and may not work as expected. Read more about the issue here
    I spoke to the developers, but no lick on this.
    Any suggestions ?
    Tony

    Nate Walker

    (@1791delegates)

    I am receiving the same message regarding the Astra theme: “If Menu detected that another plugin or theme (Astra_Walker_Nav_Menu_Edit_Custom) extends menu items incorrectly.”

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.