Support » Plugin: NinjaFirewall (WP Edition) - Advanced Security Plugin and Firewall » conflict with WP update 5.5: Active PHP session

  • Resolved dulleca

    (@dulleca)


    Hi, after updating to WP 5.5 error appeared under the critical Issue section in WordPress site health tool:

    “A PHP session was created by a session_start() function call. This interferes with REST API and loopback requests. The session should be closed by session_write_close() before making any HTTP requests.”

    I deactivated plugins one by one to see which one causing the error, after deactivating ninjafirewall the error despisers.

    waiting for you to investigate the problem.

    Thank you and keep up the great work.

    • This topic was modified 2 years, 3 months ago by dulleca.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author nintechnet

    (@nintechnet)

    I have the same message, despite the fact that NinjaFirewall does call session_write_close() before an HTTP request takes place.
    Can you check in the “Passed tests” section below that you have the “The REST API is available” message?

    Thread Starter dulleca

    (@dulleca)

    Yes, it shows Rest API is available.
    Thank you for the timely update.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘conflict with WP update 5.5: Active PHP session’ is closed to new replies.