Support » Plugin: WP-Optimize - Cache, Clean, Compress. » Conflict with New PHP

  • Resolved Skrlance

    (@seanlance)


    As WordPress moved to be PHP 8 compatibility. Can you please consider fixing WP-optimize plugin error when running on PHP 8. I see the following error on Dashboard:

    will be assigned to the string offset in C:\xampp\htdocs\wp-includes\class.wp-scripts.php on line 492

    I checked very good. When I disable wp-optimize plugin the error message goes away. However, it triggers back after I enable it!!

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hi there,

    The error message you shared is trunkated (the beginning is missing). Could you maybe enable it again and share the full error?

    Thanks
    Marc.

    Thread Starter Skrlance

    (@seanlance)

    Here it is:

    Warning: Only the first byte will be assigned to the string offset in D:\xampp\htdocs\wp-includes\class.wp-scripts.php on line 492

    Plugin Author David Anderson

    (@davidanderson)

    What WordPress version are you running? The message suggests that it’s a version that pre-dates PHP 8 and isn’t compatible.

    Thread Starter Skrlance

    (@seanlance)

    I am running WordPress v5.6 n that’s latest.

    I have the same message – /home/clients/38b85735a6c21bb97257311cf2b03aa9/web/wp-includes/class.wp-scripts.php on line 492.

    Running PHP 8.0 and WP 5.6.

    Hi there,

    Thank you for reporting this.
    I’ve found the issue and we will add a fix ASAP.
    Note that it’s only a warning, and shouldn’t affect functionality.

    Marc.

    Hello, i received the same error today as soon as i activated plugin Popup Maker – Popup Forms, Opt-ins & More: Warning: Only the first byte will be assigned to the string offset in C:\xampp\htdocs\wp-includes\class.wp-scripts.php on line 492
    Using WP version 5.6

    Thank you for checking

    • This reply was modified 1 year, 9 months ago by MargoV.

    I see the same when I activated Styler for WPF forms and WPForms Lite plugins
    Please Fix Them

    I received the same error when I activated the popup plugin!!! Any solution, please

    Thread Starter Skrlance

    (@seanlance)

    Guys, it’s not good to eat the brain of a developer because he doesn’t concern any other plugin than his own. So, stop posting irrelevant comments. If you like to talk about some other plugin, post in the support of those plugins not here ok!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Conflict with New PHP’ is closed to new replies.