WordPress.org

Forums

WP Symposium Toolbar
[resolved] Conflict with mobile menu (8 posts)

  1. style960
    Member
    Posted 1 year ago #

    I'm using the Buddyboss theme which uses the toolbar to create menu buttons on mobile. The left button on the site below should show login/register when expanded, but doesn't when WP Symposium is enabled.

    http://falcon.everygoalmatters.com

    Can you advise?

    Thanks,
    Paul.

    https://wordpress.org/plugins/wp-symposium-toolbar/

  2. Guillaume Assire
    Member
    Plugin Author

    Posted 1 year ago #

    I don't see the Toolbar when logged-out, I have registered an account on your site and do see it when logged in, however there are conflicts indeed with what your theme provides.

    When logged out the Toolbar (#wpadminbar) isn't displayed at all to visitors. Have you checked the "visitor" checkbox for the Toolbar, at the "Toolbar" tab of the plugin settings page ? When logged in, it hides the Toolbar, I see a display:none under some conditions, located in adminbar-mobile.css. You should check if you can deactivate those features from your theme, or maybe that's the way it is designed ?

  3. style960
    Member
    Posted 1 year ago #

    The toolbar is not shown to logged-visitors, that's correct. The css you've identified is part of the theme styling. If you look at the address below, you'll see the Login/Register links behind the left button that are lost when I enable Symposium:

    http://style960.com/demo-buddyboss/

    BuddyBoss support have suggested I look at adding the header code which generates these links to Symposium?

  4. Guillaume Assire
    Member
    Plugin Author

    Posted 1 year ago #

    I'm not sure I fully understand your issue. Thanks for the demo site.

    At the time of responding I see both links at the upper right corner, on both sites. What do you mean by "enabling Symposium", do you mean WPS Toolbar ? Could you make it so that these buttons actually disappear on one of the sites ?

    As for adding the code for the buttons for the Toolbar, items are generated as li's by WordPress, so maybe with a bit of CSS you could make them look the way you want.

  5. style960
    Member
    Posted 1 year ago #

    If you access that site on a mobile and press the left button, you'll see the Login & Register links and rendered there, as opposed to the header on a larger display. When I enable WPS Toolbar something is causing those links to not show, although the button works fine. And when logged-in, the user account menu this button activates also still works. I suspect it's a CSS conflict that's causing the Login & Register links to still be rendered but they're not visible on mobile.

  6. Guillaume Assire
    Member
    Plugin Author

    Posted 1 year ago #

    Ah, I see it now, when you press the "house" icon...

    Could you go to WPS Toolbar settings > Toolbar, and check "visitor" for the display of the Toolbar, the very first option at this tab. Or confirm this is done already...?

  7. style960
    Member
    Posted 1 year ago #

    Referring to your earlier suggestion - I ticked the Visitor box for WP Toolbar, and the links have returned on mobile. Thanks for your help.

  8. Guillaume Assire
    Member
    Plugin Author

    Posted 1 year ago #

    Great! Actually, given the theme, I would recommend to check all roles there.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Symposium Toolbar
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic