Support » Plugin: Webmaster User Role » Conflict with "Members" plugin

  • Resolved hakonzen

    (@hakonzen)


    When I updated “Members” by JustinThadlock, I got this message;
    “Fatal error: Cannot redeclare members_get_capabilities() (previously declared in /var/www/vhosts/kvinnerinettverk.no/wp-content/plugins/webmaster-user-role/includes/module-gravity-forms.php:174) in /var/www/vhosts/kvinnerinettverk.no/wp-content/plugins/members/inc/functions-capabilities.php on line 106”
    So theres definitely some conflict here
    We don´t use gravity forms, so this line is possible not necessary for us, but I could not mark it out since it caused “white screen”
    I had to disable the members plugin for now, but really need it, so if you got a fix, that would be great!

    https://wordpress.org/plugins/webmaster-user-role/

Viewing 3 replies - 1 through 3 (of 3 total)
  • I have talked to Justin Tadlock, author of the Memvers plugin, and he states that the members_ function name prefix is unique to his plugin, and that using there to together causes the error, see https://wordpress.org/support/topic/fatal-error-upon-update-1?replies=2#post-7433710
    Hope you can correct this so errors like this is avoided?

    Plugin Author TylerDigital

    (@tylerdigital)

    Hi there—

    We’ve just pushed an update to the repo that should fix this conflict. You should see an update to version 1.3.3 on your dashboard very soon. If you don’t see the update right away, you can usually force your site to check in with WordPress by hitting “Check Again” under /wp-admin/update-core.php

    Let us know if you have any more issues!

    Phil

    Hi again!
    I have updated the plugin to 1.3.3 and activated Members again, this time without the conflict. Great respons to my problem, thanks a lot!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Conflict with "Members" plugin’ is closed to new replies.