• Resolved Nazar Hotsa

    (@bugnumber9)


    Hiya,

    Just noticed a conflict with MailPoet plugin. MailPoet is configured to send via SMTP too.
    When I try to send a test email with FluentSMTP I get this error:
    Oops! PHPMailer is modified by MailPoet\Mailer\WordPress\WordPressMailer.

    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Shahjahan Jewel

    (@techjewel)

    Hello @bugnumber9
    If you want to use FluentSMTP please disable mailpoet’s SMTP otherwise it will not work.

    Thanks

    Thread Starter Nazar Hotsa

    (@bugnumber9)

    Hey @techjewel

    That’s unfortunate 🙁
    I wanted to switch from WP Mail SMTP (which works fine with MailPoet) to FluentSMTP, this conflict makes it impossible to switch…

    Anyway, thanks for getting back to me.

    you still can, this issue only pops up when you use the advanced feature here so that mailpoet sends all your emails, and having both mailpoet and fluentsmtp handle these gives an obvious conflict. Disable the option below and you can use both, mailpoet for your newsletters, fluentsmtp for the rest

    https://kb.mailpoet.com/article/292-choose-how-to-send-your-wordpress-websites-emails

    Thread Starter Nazar Hotsa

    (@bugnumber9)

    The point is that one plugin should not be dictating the behavior of the other.
    Currently, we have MailPoet that uses an external SMTP service for outgoing emails, and we have Post SMTP plugin for all WP/Woo emails.
    This combo works flawlessly, which means it’s possible to achieve.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.