Support » Plugin: Autoptimize » Conflict with Live Mesh Post Grid ‘Load More’

  • Resolved writecharlie

    (@writecharlie)


    Hi
    Hoping someone can help. I have a post grid with a load more button. I know there are issues with Lazy Loading so I’ve removed that. The grid works well on desktop but doesn’t load on mobile, stuck on spinning.
    The plugin authors came back with this explanation/solution – You have a security exception on your site which results in load more not working. The autooptimize caching time limit needs to be decreased to 1 hour (upto 4 hours may work but you need to try out and verify this) so that the AJAX requests can pass through security check enforced by the plugin for these requests. The nonce security token issued by WordPress lasts only for max of 4 hours and hence if you keep the server cache to have a limit of more than 4 hours, an exception is raised that the token is no longer valid and hence cannot let the request to pass through resulting in 403 request forbidden error.

    Pls change the settings on your auto-optimize to refresh the cache every 1-2 hours to resolve this error.

    Does that make any sense? I’m confused.
    Many thanks
    Charlie

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    That’s not something for Autoptimize, but for the page cache you’re probably using Charlie. Autoptimize does not cache pages, so the nonces aren’t cached by it either.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.