Support » Plugin: Checkout Field Manager (Checkout Manager) for WooCommerce » Conflict with latest version of Stripe plugin

  • Resolved Brad Delaney

    (@braddelaney)


    Hello,

    Just wanted to inform you that there is a conflict with version 5.0 of the Stripe plugin that is causing a 500 ERR – this is caused by line 664 in the latest version of their plugin and is rendering the checkout page on sites using Checkout Manager unusable. Check here for more details: [ link deleted, please provide your own details in your own topic here ]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter Brad Delaney

    (@braddelaney)

    The previous version of the Stripe plugin worked fine with Checkout Manager. Stripe Version 5.0 is causing conflicts with Checkout Manager.

    I’m getting 500 errors upon the move to the checkout page. My PHP log is showing it as an issue with code on line 664 in the Stripe plugin.

    PHP Fatal error: Uncaught Error: Call to a member function get_upe_enabled_payment_method_ids() on null

    This only became a problem after the rollout of the latest version of the Stripe plugin which was rolled out yesterday. Stripe developers broke another plugin. They should take responsibility and fix it.

    Thread Starter Brad Delaney

    (@braddelaney)

    The WooCommerce developer working on the Stripe plugin created a conflict with the code in the latest version of their plugin – and instead of fixing it, he is suggesting that site developers deactivate the Checkout Manager plugin – and blow up their client’s live sites. That is not a reasonable response. I identified the issue, notified the developer who caused the issue with detailed information on what in their code is causing the issue.

    • This reply was modified 1 week, 6 days ago by Jan Dembowski.
    • This reply was modified 1 week, 6 days ago by Ipstenu (Mika Epstein). Reason: Removed incorrectly complaint about being muted
    Plugin Author quadlayers

    (@quadlayers)

    Hello @braddelaney
    Thanks for reporting issue
    However we dont know what could be causing the incompatibility
    Our plugin doesn’t has any method called
    get_upe_enabled_payment_method_ids
    Maybe if more users ask for a fix they will take care of it
    If you find a way to fix this from our side please share the code here

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.