Support » Plugin: Relevanssi - A Better Search » Conflict with Gutenberg 4.7 rc1 – Cant save

  • Resolved slimmilkduds

    (@slimmilkduds)


    Hi, just a heads up that there seems to be a conflict with the latest RC of Gutenberg (released like an hour ago). Running WP 5 + Latest Relevanssi + GB 4.7 rc makes it impossible to save drafts or publish custom posts. Regular posts works fine, deactivating Relevanssi also makes it work.

    Cheers

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Mikko Saari

    (@msaari)

    Ah, the reusable block handling has changed again in Gutenberg. Looks like this is already broken in 4.6.1.

    For a quick fix, replace the relevanssi_gutenberg_block_rendering() function in /lib/compatibility/gutenberg.php with this:

    function relevanssi_gutenberg_block_rendering( $content, $post ) {
    	return do_blocks( $content );
    }

    That should fix the problem.

    Thread Starter slimmilkduds

    (@slimmilkduds)

    Great, works like a charm!

    Plugin Author Mikko Saari

    (@msaari)

    Good, this fix is included in Relevanssi 4.1.2 so you can update safely.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Conflict with Gutenberg 4.7 rc1 – Cant save’ is closed to new replies.