Support » Plugin: Advanced Custom Fields: Extended » Conflict with Gravity Forms plugin

  • Resolved martinjstephens

    (@martinjstephens)


    Hi,

    We’ve identified a conflict between ACF Extended and Gravity Forms. When updating a page that has a Gravity Forms shortcode on it, we’re taken to a whitescreen and the URL changes to /wp-admin/edit.php . The page does not update.

    The whitescreen page, when inspected, shows validation elements generated by Gravity Forms. It appears that Gravity Forms is trying to validate the form as if it was being submitted when Update is being clicked. Deactivating the ACF Extended plugin allows us to update the page without the error and we have to leave this plugin deactivated whilst this error is happening.

    It would be great if this can be tweaked for a future release so that all pages featuring a Gravity Form can be updated without an error occurring.

    Thanks
    M

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author hwk-fr

    (@hwk-fr)

    Hello,

    Thanks for the feedback! May I ask you what kind of ACF field do you use in your page administration?

    The Gravity Form shortcode isn’t supposed to be rendered by WordPress in the administration. Unless you use the Flexible Content Render with Preview Mode, which means the Gravity Form HTML is actually rendered in the preview, and thus, submitted during the update.

    A screenshot of your admin page would help to understand quite better what’s going on.

    Regards.

    Plugin Author hwk-fr

    (@hwk-fr)

    Hello,

    Any news?

    Regards.

    Plugin Author hwk-fr

    (@hwk-fr)

    Hello,

    I’m closing the issue since there is no new information. If you use the gravity form inside the Flexible Content Dynamic Preview (in the admin), then you should make sure to display the shortcode within a if(!$is_preview){} conditional.

    Feel free to answer if you have any new information.

    Hope it helps!

    Regards.

    Thread Starter martinjstephens

    (@martinjstephens)

    Hi Konrad,

    Sorry for the delay in coming back to you. Several of us were off for Christmas for a few weeks.

    We’ve added the check you have recommended in your last reply and this appears to have solved our issue. Thanks for that.

    KR
    Martin

    Plugin Author hwk-fr

    (@hwk-fr)

    Hello,

    Good to hear! I will try to find a solution in the next patch, as users have the same problem when using ACF/ACF Extended Forms. I’ll try to disable Gravity/ACF Forms in the Flexible Content preview mode.

    Have a nice day and happy new year! 🙂

    Regards.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Conflict with Gravity Forms plugin’ is closed to new replies.