Support » Plugin: WPBruiser {no- Captcha anti-Spam} » Conflict with Gravity Forms Page Breaks

  • I am having problems using WPBruiser (WPB) with Gravity Forms (GF). I purchased the GF unlimited add-on. However, when I activate it any GF that has page breaks does not submit. I get the confirmation page saying it has submitted, but it doesn’t show up in my entries, nor does it send an email confirmation. I removed the page breaks and the same form submitted correctly. Additionally, when I turn off the GF option in WPB, the form with page breaks submits correctly. I have contacted WPB support with this question but have not received a response. Any help here would be appreciated. Thanks.

Viewing 1 replies (of 1 total)
  • On my WP site with GF and WPB/GF Extension plugins installed the same problem occurs:
    Notification emails are not sent from Gravity Forms in case the form has a) multiple pages and b) uses Ajax (GF shortcode: ‘ajax=true’).

    Cause: WPBruiser/GF Extension rejects emails to be sent as spam. Error: ‘Invalid token’. Reason: hidden input field that should contain token is empty.

    Technical background
    ====================
    Token setting mechanism:
    1. Field <input type=’hidden’ name='[name]’ value='[value]’> is generated in WPB GdbcGravityFormsPublicModule.php / function appendHiddenFieldIntoGravityForms().
    2. [value] is set by gdbc-client-new.js.php / function retrieveToken() using Ajax.

    Cause of error: function retrieveToken() is only called for the FIRST page at form callup. For subsequent pages only step 1 above is executed because paging is done using Ajax (form is NOT resubmitted), causing [value] to be empty at submit from last page.

    Plse fix.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.