Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » Conflict with featured image and other custom post type

  • Resolved Guido

    (@guido07111975)


    Hi,

    I’m having a serious conflict between NGG and plugins that register a custom post type (such as event) and support the featured image:

    
    'supports' => array('title', 'thumbnail', 'editor')
    

    When creating a new event and clicking the Featured Image box there’s this warning:

    
    TypeError: Unable to get property 'ngg_post_thumbnail' of undefined or null reference
       at Anonymous function (my-domain/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_block/static/build/post-thumbnail.min.js?ver=3.2.2:1:13819)
       at n (my-domain/wp-includes/js/dist/data.min.js?ver=4.4.0:1:15085)
       at r (my-domain/wp-includes/js/dist/data.min.js?ver=4.4.0:1:15176)
       at Yf (my-domain/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:67:40)
       at qg (my-domain/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:92:302)
       at hi (my-domain/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:104:223)
       at Qg (my-domain/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:144:211)
       at Rg (my-domain/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:145:74)
       at Sc (my-domain/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:158:109)
       at Z (my-domain/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:156:492)
    

    This even happens with a custom build plugin that only contains the necessary code.

    So there must be a conflict with the ngg_post_thumbnail somehow..
    I’m not the only one having this problem. Please check this thread as well.

    Can you please take a look at this?

    Guido

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support mihai-imagely

    (@mihaiimagely)

    Hi @guido07111975,

    I am sorry to hear of the problem. I hope that you wouldn’t mind verifying for a plugin conflict just to make sure that there aren’t any other plugins conflicting with NextGen Gallery and Register Custom Post Type plugin by temporarily deactivating any other plugins excepting these and using a theme from the generic Twenty series.

    Please let us know how it goes,
    Thanks

    Thread Starter Guido

    (@guido07111975)

    Hi @mihaiimagely,

    Active:
    Twenty Nineteen
    NGG
    My test plugin

    Test plugin contains this code only:

    
    <?php
    /*
     * Plugin Name: CPT Guido
     * Description: Example plugin that adds Guido post type.
     * Version: 0.1
     * Author: Guido
     */
    
    // create guido post type
    function add_post_type() {
    	$labels = array(
    		'name' => 'Guido'
    	);
    	$args = array(
    		'labels' => $labels,
    		'public' => true,
    		'can_export' => false,
    		'show_in_nav_menus' => false,
    		'has_archive' => false,
    		'show_ui' => true,
    		'show_in_rest' => true,
    		'capability_type' => 'post',
    		'supports' => array('title', 'thumbnail', 'editor'),
    	);
    	register_post_type( 'guido', $args );
    }
    add_action( 'init', 'add_post_type' );
    

    Same error/warning when clicking the Featured Image box.

    Guido

    Plugin Support gabyimagely

    (@gabyimagely)

    Hello @guido07111975

    We want to take a second look to this particular conflict you are experiencing with NextGen Gallery and plugins that register a custom post type. We may need to deactivate plugins and switch the theme while troubleshooting temporarily. Would you feel OK with that?. If so, please report this issue as a bug using this form: https://www.imagely.com/report-bug/. Be as specific as possible and let them know Gaby referred you.

    Note: do not forget to include this forum’s link.
    Many thanks!

    Thread Starter Guido

    (@guido07111975)

    Hi @gabyimagely

    I’ve created a ticket. FYI, the ticket number is 286303.

    Guido

    Plugin Support gabyimagely

    (@gabyimagely)

    Hi @guido07111975

    Thank you so much for letting us know.
    I can see the ticket in the inbox.
    We’ll keep the conversation from there.
    Many thanks!

    Plugin Support gabyimagely

    (@gabyimagely)

    Thanks again!
    This particular ticket is now reported as a bug to our developers.

    @gabyimagely I’m having the same issue. I’m using CPT UI to register my custom post types.
    Do you have any update on this bug?

    Just another update – I found this thread which suggested using the Classic Editor instead, so I’ve switched to that and things seem to be working. Would really like to be able to use the newer block editor with this though!!

    Thread Starter Guido

    (@guido07111975)

    Hi Kay,

    There’s still an open ticket (bug report) and I’ve asked about the status 4 weeks ago, but they had other priorities first. So still nothing is done regarding this issue 🙁

    Guido

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Conflict with featured image and other custom post type’ is closed to new replies.