Support » Plugin: Post State Tags » conflict with enfold theme and custom type

  • Hi,

    I had to deactivate this great plugin because of a fatal error it gives when visiting the post list admin page for a custom post type (created with “Custom Post Type UI” plugin), and while using the Enfold theme.

    This is the relevant part in debug.log for Enfold v 4.7.2:

    PHP Fatal error:  Uncaught TypeError: Argument 1 passed to Avia_Gutenberg::handler_display_post_states() must be of the type array, null given, called in /home/XXX/public_html/wp-includes/class-wp-hook.php on line 288 and defined in /home/XXX/public_html/wp-content/themes/enfold/config-gutenberg/class-avia-gutenberg.php:657
    Stack trace:
    #0 /home/XXX/public_html/wp-includes/class-wp-hook.php(288): Avia_Gutenberg->handler_display_post_states(NULL, Object(WP_Post))
    #1 /home/XXX/public_html/wp-includes/plugin.php(206): WP_Hook->apply_filters(NULL, Array)
    #2 /home/XXX/public_html/wp-admin/includes/template.php(2168): apply_filters('display_post_st...', Array, Object(WP_Post))
    #3 /home/XXX/public_html/wp-admin/includes/template.php(2077): get_post_states(Object(WP_Pos in /home/XXX/public_html/wp-content/themes/enfold/config-gutenberg/class-avia-gutenberg.php on line 657

    thank you

Viewing 1 replies (of 1 total)
  • Plugin Author John Brand

    (@brandbrilliance)

    I see. However none of the folders above is generating an error with post-state-tags anywhere so it doesn’t appear to be my plugin that is generating an error. But rather the Avia Gutenberg and Enfold.

    If you can tell me what customer post status you added and how then I can try to replicate this issue.

Viewing 1 replies (of 1 total)
  • The topic ‘conflict with enfold theme and custom type’ is closed to new replies.