Support » Plugin: Collapsing Archives » Conflict with Enfold theme

  • Resolved mowse.ink

    (@mowse)


    Hi, y’all…

    Collapsing Archives has stopped working with Enfold (even though it was working with an earlier version of WP). Any chance you can give it a look-see?

    adamoverett.com

    I’m getting this error in the console:

    [Error] TypeError: undefined is not a function (evaluating 'jQuery('#' + id + ' span.expand').live')
    	addExpandCollapse (adamoverett.com, line 570)
    	global code (adamoverett.com, line 610)

    Any idea what’s going on?
    —jonathan

    https://wordpress.org/plugins/collapsing-archives/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter mowse.ink

    (@mowse)

    I should add…It works fine with Twenty-Fifteen, so it’s obviously a theme conflict.

    Thread Starter mowse.ink

    (@mowse)

    Bump this help request, as I submitted it two weeks ago.

    Is there a way of resolving this problem, which seems like a jQuery conflict with the them? I’d appreciate any help you could provide.

    Thanks!
    —jonathan

    Thread Starter mowse.ink

    (@mowse)

    Okay…got rid of the conflict error, but the archive links still aren’t behaving correctly. Now they expand and contract as they should, but if I click on a year or month, it goes to that archive instead of staying on the same page as it expands. (I have selected the proper setting in the widget “expands list,” not “Links to archive.”)

    Any ideas what the conflict would be now? It’s not throwing any errors in the console.

    adamoverett.com

    Thread Starter mowse.ink

    (@mowse)

    Solved. The conflict was being caused by a smooth page transition option in the Enfold theme settings. Upon disabling it, all is working as it should.

    Thread Starter mowse.ink

    (@mowse)

    Topic resolved.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Conflict with Enfold theme’ is closed to new replies.