Support » Plugin: Autoptimize » Conflict with Elementor Pro

  • Resolved mikatalin

    (@mikatalin)


    Hi there, I’ve been using Autoptimize for a long time and worked fine, loved it. I’ve recently bought Elementor Pro, a page builder plugin. Unfortunately there’s a conflict between the 2 plugins so I had to deactivate Autoptimize. What I’m saying is that Autoptimize is a great plugin, but does not tolerate Elementor Pro. The Elementor team knows about this issue, I think Autoptimize team should be informed as well. I’d return using Autoptimize if the conflict was solved.

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Author Frank Goossens

    (@futtta)

    interesting, I’ll be happy to assist, but can you provide more information mikatalin;
    * does the conflict happen for the administrator using elementor pro, or for visitors?
    * in case of administrator; did you try to pagebuilder-problem fix from AO’s FAQ?
    * in case of visitors; what JS-errors do you see on the browser console? did you try some of the troubleshooting tips from the FAQ (e.g. excluding elementor JS from optimization)?

    frank

    Thread Starter mikatalin

    (@mikatalin)

    Hi Frank,

    Thanks for your message. What happened was that the image carousel made with Elementor Pro didn’t show in any browsers (Firefox, Chrome, IE, Safary). I checked everything on both Windows and Mac laptops, a Samsung smart phone and an iPad. Visitors saw a blank white space where the carousel should have been. I didn’t try excluding elementor JS from optimization, I would if I knew how to do so. I will search FAQ and try to do something because I liked Autoptimize very much. My site is a webshop (WP and Woocommerce) and I’m a bit afraid of experimenting.
    Best regards, Katalin

    Plugin Author Frank Goossens

    (@futtta)

    the FAQ should help indeed. the shortcut;
    * disable only JS optimization to confirm this is the problem
    * re-enable JS optimization (keep defaults; don’t aggregate inline JS, don’t force in head, make sure js/jquery/jquery.js is excluded from JS optimization)
    * go to the front-end of your site, open developer tools (or whatever it’s called) and look for JS errors there

    based on those JS errors (and the source of an un-optimized page, simply add ?ao_noptimize=1 to the URL) one generally can deduct what JS one might have to exclude from optimization.

    hope this clarifies,
    frank

    MDC2957

    (@mdc2957)

    Hi Frank,
    I’m also using Elementor and trying to figure out a similar issue. When I disable the js optimization, the second error in the image, referring to jquery.js comes up and that causes things like slider, smooth scroll, and popup not to work. I don’t understand why this would happen because according to AO, seal.js, js/jquery/jquery.js are excluded by default when you turn on the js optimization. I really want to be able to use your plugin, because it takes my site from over 10 seconds loading time to below 2 seconds. Hope you can help!

    console

    (open image in the new tab to see it better)

    Plugin Author Frank Goossens

    (@futtta)

    hey @mdc2957; is this to “edit” an elementor-drive page as admin, or to “view” an elementor-based page?

    frank

    MDC2957

    (@mdc2957)

    Hi Frank, thanks for the reply. No, this is for front end view, that any visitor to the site would see. On my home page, I have some menu anchors that are supposed to smooth scroll down the page. As well as a button triggered popup maker popup, and an Elementor slides element.

    Plugin Author Frank Goossens

    (@futtta)

    I’m trying to see your site unoptimized by adding ?ao_noptimize=1 to the URL, but your page cache is ignoring the querystring, could you change that setting?

    MDC2957

    (@mdc2957)

    I think that’s cloudflare’s caching level. It was on ignore query string. I just changed it to Standard. Is that correct?
    I should also let you know, I put:
    wp-includes/js/jquery/jquery.js, wp-content/themes/oceanwp/assets/js/main.min.js
    into the exclude scripts box earlier. Do you want me to remove those?

    Plugin Author Frank Goossens

    (@futtta)

    I think that’s cloudflare’s caching level. It was on ignore query string. I just changed it to Standard. Is that correct?

    it should be, but still no luck; could it be you also have a page caching plugin or that your hoster has a cache which needs configuring?

    MDC2957

    (@mdc2957)

    For testing, I’ve started a digital ocean server here:
    http://wordpress-40513-85601-238117.cloudwaysapps.com/
    I deactivated the SiteGround cache plugin, and this site isn’t going through cloudflare. Perhaps testing in this environment will help some?

    Plugin Author Frank Goossens

    (@futtta)

    afraid not. but if this is an identical setup, disable AO on this one, then I can the 2 sites to see the difference?

    MDC2957

    (@mdc2957)

    I’ve deactivated AO on the cloudways server link

    Plugin Author Frank Goossens

    (@futtta)

    sorry @mdc2957, didn’t have time yet, hope to look into this tonight or tomorrow.

    MDC2957

    (@mdc2957)

    It’s ok, I’m on the free trial period for cloudways and I think it has 10 more days or so… Considering moving my site to them

    Plugin Author Frank Goossens

    (@futtta)

    OK, compared the 2 sites:
    * slider seems to work on both
    * anchor-links work on the site with AO, not on the one without AO?

    so I’m not entirely sure what I should be looking for here? can you re-state the issue you’re encountering with AO?

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Conflict with Elementor Pro’ is closed to new replies.