Support » Plugin: SG Optimizer » Conflict with Elementor plugin

  • Resolved rarcher30

    (@rarcher30)


    Not sure if this is a memory usage issue or my particular configuration but I do know both the latest versions of this plugin and the Elementor plugin are causing me not to be able to edit ANY of my pages in Elementor.

    Will be disabling this plugin until I can sort out the issue. Lot’s of other optimization alternatives thankfully.

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    The new plugin works fine with Elementor, I’ve tested it numerous times personally. What do you mean by not being able to edit any of your pages, the cache is not cleared, changes not saved or something times out?

    Thread Starter rarcher30

    (@rarcher30)

    What happens is that I cannot get to edit my page in Elementor. Screen just appears white with the option to turn on safe mode. This does let me access the page but it strips out most of the styling and tells me to check this link out – https://go.elementor.com/safe-mode-helped/

    Ok So I purged the cache on SG. I don’t have too many plugins installed, just an average amount. I went through the Elementor recommended steps to debugging the issue and the only thing I can find constant is that activating the SG Optimizer plugin means that I cannot load the Elementor page editor.

    I haven’t dug around any deeper than this as all things point towards the SG Optimizer plugin. I also have the EA for Elementor and the Premium Addons for Elementor plugins installed.

    Strangely wasn’t happening before until I upgraded both Elementor and the SG Optimizer plugins.

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    Try adding this to your .htaccess file and let me know how your site behaves please:

    <IfModule mod_substitute.c>
    SubstituteMaxLineLength 10M
    </IfModule>
    mirademeterphotography

    (@mirademeterphotography)

    Hi, I have exactly the same problem as the @rarcher30 . I have to switch off the SG to go through to the Elementor.
    Problem is I have no idea what the htaaccess file is and where it is, can you help please? Thank you

    mirademeterphotography

    (@mirademeterphotography)

    Is there anyway of going back to before the update? Sorry my knowledge is very limited. Thank you

    Thread Starter rarcher30

    (@rarcher30)

    Ok with a hard refresh, @hristo-sg your solution appeared to work. I suspect it is a memory/resource issue? What does that line of code in .htaccess do anyway? It appears to me it allows a 10MB character limit length – which is HUUUUGE!

    Is there any potential downside to this bit of code effecting my site or using up too much server resources now?

    A quick google search has told me that Visual Composer, DIVI and some other page builders have experienced similar issues. Yeah this tweak makes the page load much faster in Elementor editor – would just like to know what it actually does.

    Thread Starter rarcher30

    (@rarcher30)

    @mirademeterphotography if you have a file manager on your host control panel, you should be able to edit the .htaccess file. Or you can go through the WordPress “trac” to find the previous version of the SG Optimizer plugin and install it.

    If you need some help with editing the .htaccess file, reach out to me privately on https://coolwebs.com.au or https://facebook.com/izzcoolwebs

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    Elementor needs a lot of that in case you’ve selected CSS to be generated inline the page and not on separate files.

    Elementor -> Settings -> Advanced -> CSS Print Method -> External File instead of Internal Embedding should work fine without the above mentioned line.

    As to whether there are any downside of it, not really, the server takes the load of extra memory being reserved for that.

    The new SG Optimizer version has much better interface and purging mechanism. I would advice against using older versions. In your case I beelieve that extra few bytes just tipped over the limit.

    mirademeterphotography

    (@mirademeterphotography)

    May I ask, I have found the htaccess file

    Have I done this correctly? Is it in the right place?

    Thank you for all your help @hristo-sg and @rarcher30

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    <IfModule mod_substitute.c>
    SubstituteMaxLineLength 10M
    </IfModule>

    # END WordPress

    Thread Starter rarcher30

    (@rarcher30)

    Almost. It appears as if you have nested an <IfModule> tag inside itself.
    Please close the first tag and then make a carriage return space and past that code separately.

    Hope you know what I mean.

    You will also need to do a hard refresh on your browser to see any changes. Make sure you have any caches purged as well.

    mirademeterphotography

    (@mirademeterphotography)

    @rarcher30 Thank you, does this look better?

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    <IfModule mod_substitute.c>
    SubstituteMaxLineLength 10M
    </IfModule>

    # END WordPress

    I am going to google what is hard refresh ( I seriously have no clue). Thank you for helping.

    Thread Starter rarcher30

    (@rarcher30)

    Yup that looks right. The refresh is easy, just hold down the SHIFT key when you click on the refresh button in your browser.

    mirademeterphotography

    (@mirademeterphotography)

    @rarcher30 Thank you for all your help. I have tried it all but it does not work. I will try to figure out how to use the previous version and hope the next upgrade fixes it. Thank you

    mirademeterphotography

    (@mirademeterphotography)

    Hi
    now I have no idea if this makes any difference but I have been searching through everything and noticed that PHP was on 5.6 version. I have upgraded it to 7.1 and everything started working. Not sure if it is related at all but yeah so happy. Thank you

    Thread Starter rarcher30

    (@rarcher30)

    Yeah that probably had something to do with it. PHP7+ are way more efficient, faster and lighter on server resources than 5.6 was. No sites should be running on 5.6 these days (unless there are some dependencies that haven’t been patched yet).

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Conflict with Elementor plugin’ is closed to new replies.