Support » Plugin: Yoast SEO » Conflict with Elementor Header & Footer Builder

  • Resolved NicheLabs

    (@allennichelabs)


    When I have both Yoast and Elementor Header & Footer Builder active, when going to the setups for Elementor Header & Footer Builder I get “Your Site Is Experiencing A Technical Issue” and when I check my error log I get see the error I posted at the bottom.

    When I deactivate Yoast the other plugin works just fine.

    I’ve posted a support request with the other developer but thought I would post one here as well.
    https://wordpress.org/support/topic/conflict-with-yoast-24/

    Here is the error I’m getting:

    PHP Fatal error: Uncaught TypeError: Argument 1 passed to WPSEO_Abstract_Post_Filter::add_filter_link() must be of the type array, boolean given, called in /home/theissalawfirm/public_html/_production/wp-includes/class-wp-hook.php on line 292 and defined in /home/theissalawfirm/public_html/_production/wp-content/plugins/wordpress-seo/admin/filters/class-abstract-post-filter.php:101
    Stack trace:
    #0 /home/theissalawfirm/public_html/_production/wp-includes/class-wp-hook.php(292): WPSEO_Abstract_Post_Filter->add_filter_link(false)
    #1 /home/theissalawfirm/public_html/_production/wp-includes/plugin.php(212): WP_Hook->apply_filters(false, Array)
    #2 /home/theissalawfirm/public_html/_production/wp-admin/includes/class-wp-list-table.php(405): apply_filters(‘views_edit-elem…’, Array)
    #3 /home/theissalawfirm/public_html/_production/wp-admin/edit.php(457): WP_List_Table->views()
    #4 {main}
    thrown in /home/theissalawfirm/public_html/_production/wp-content/plugins/wordpress-seo/admin/filters/class-abstract-post-filter.php on line 10

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support devnihil

    (@devnihil)

    @allennichelabs We’re sorry to hear you are experiencing this issue on your site.

    Can you please confirm you are using the most recent release of Yoast SEO version 16.5? You can learn more about updating here: https://yoast.com/help/how-can-i-update-my-free-plugin/

    Also, can you confirm you are using WordPress 5.7.2? You can check by clicking on the W in the top left and selecting About. If you need to update, please check with your host provider. Please know that if you are using an older version of WordPress Core you may experience unexpected behavior with Yoast. This guide explains more: https://yoast.com/why-we-dont-support-old-wordpress-versions/

    If you update to the most current version of WordPress and Yoast SEO, does this resolve the issue?

    If you have confirmed both WordPress, Yoast SEO, and all of your site’s other plugins and themes are up to date and the problem is still occurring, we would next recommend performing a conflict check. A plugin or theme conflict can sometimes cause functionality problems, errors, or unexpected behavior from the plugin. If you are unfamiliar with checking for conflicts, we have a step by step guide on how to check for conflicts available here: How to check for plugin conflicts.

    Test this on your development or staging site, if you have one. If not, we recommend using the Health Check & Troubleshooting plugin. This plugin allows you to run a conflict check without affecting normal visitors to your site.

    Can you please confirm you have performed a complete conflict check by disabling other plugins, and resetting the theme to a default such as TwentyTwentyOne and let us know the results?

    If you do not feel comfortable to do this yourself or if this does not solve your issue, our Yoast SEO Premium plugin comes with one year of (technical) support.

    Thread Starter NicheLabs

    (@allennichelabs)

    Thank you for the quick response. Yes, I am running the latest versions of WP and all plugins.

    It is definitely a conflict with Elementor Header & Footer Builder
    https://wordpress.org/plugins/header-footer-elementor/

    When I disable Yoast, that plugin works. When I reactivate Yoast I get the error I described above. If I deactivate Elementor Header & Footer Builder then I don’t get an error from Yoast.

    I don’t know which plugin is actually causing the problem, I just know that Yoast is what is reported in the error log.

    I have contacted the developer of Elementor Header & Footer Builder as well but have not heard back from them, so in the mean time I’ve deactivated their plugin since I need Yoast functioning more than I do the other plugin.

    Plugin Support Michael Tina

    (@mikes41720)

    Hi @allennichelabs

    We appreciate the information you’ve provided. But just to clarify, were you able to perform a conflict check using either a staging site or troubleshooting mode of the Health Check plugin?

    We need to be able to identify the minimum set-up in order to reproduce this issue. So if the fatal error occurs with only a default WP theme such as TwentyTwenty, and only Yoast SEO v16.5 and the latest versions of the Elementor and Elementor Header & Footer Builder plugin, we recommend that you create a new bug report on our GitHub repository. We have an article that will help you with all of the necessary information you need to provide – https://yoast.com/help/how-to-write-a-good-bug-report/

    Plugin Support Michael Tina

    (@mikes41720)

    Hi @allennichelabs

    Upon doing some further tests, we had a test site with WP 5.7.2 and the default WP theme of TwentyTwenty. We then made sure that only Yoast SEO v16.5, Elementor v3.2.5, and Elementor Header & Footer Builder v1.6.1 were the only plugins enabled. Once we created a test template, we were then able to reproduce the fatal errors reported.

    Thank you for bringing this issue to our attention!

    We apologize for the trouble you are currently experiencing with our plugin. Luckily, a so-called “bug report” (a description of the issue, so we can fix it) is filed already.

    What’s next?
    Our product team will assess the severity of this problem in relation to other open bug reports and new features. Based on their assessment, the bug report will be given a priority level. Our developers work on the highest priority issues first. Unfortunately, this means we cannot give you an estimate of when they’ll start working on your report.

    If you have any further information that may affect the prioritization or help our development team solve this bug, please feel invited to reply to this forum topic.

    We also recommend reaching out to the developers of the Elementor Header & Footer Builder plugin and report this issue with them as well. Having both teams working on this issue will help in order to get this resolved faster. Thanks!

    Plugin Support Jeroen Rotty

    (@jeroenrotty)

    The team behind the Elementor Header & Footer Builder plugin released version 1.6.2 which should fix the fatal (as seen here). Can you please update their plugin and check if this resolves the issue for you?

    Thread Starter NicheLabs

    (@allennichelabs)

    Yes, that resolved the issue. Thank you for your help.

    Plugin Support Jeroen Rotty

    (@jeroenrotty)

    Great, happy to hear that. We’ll mark this topic as resolved. Have a great day!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Conflict with Elementor Header & Footer Builder’ is closed to new replies.