Support » Plugin: LifterLMS » Conflict with Easy Google Fonts

  • Resolved Bree

    (@lifesgood)


    Hi there, and thank you so much for this plugin.

    It seems there is a conflict with the free LifterLMS plugin and the free Easy Google Fonts plugin (so I’m not entirely sure who to raise the conflict with).

    When Lifter LMS is activated, the colour slider within the Customizer is unusable for the Easy Google Fonts plugin (https://wordpress.org/plugins/easy-google-fonts/)

    Just wondering if you have any suggestions on how to fix this?

    Thank you in advance

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Support Natalie

    (@nrherron)

    Hi @lifesgood,

    I’m sorry you’re having this issue!

    We are happy to look into this for you if you can provide us with screenshots about what you’re seeing and the steps you’re taking to encounter this issue so we can attempt to recreate it on our test sites? Just a heads up to attach screenshots you will have to use a service (Dropbox, Drive, Imgur, etc…) and post a link to your screenshot.

    Additionally if you could give us a copy of your LifterLMS System Report that would be helpful as well for us to rule out any other conflicts that could be impacting your issue! Here is a guide for finding your system report here: https://lifterlms.com/docs/how-to-use-the-lifterlms-system-report/. Also when posting your report, please follow the WordPress.org forum guidelines for posting code here: https://wordpress.org/support/forum-user-guide/faq/#i-need-to-post-code-is-that-okay.

    Let us know if you have any further questions!

    Thanks and take care,

    Bree

    (@lifesgood)

    Hi, thank you for your reply.

    Here are the requested screenshots:

    1. Easy Google Fonts colour slider without LifterLMS active
    https://www.dropbox.com/s/6xxm8y7xsdq21t9/lmsegf1.PNG?dl=0

    2. Easy Google Fonts colour slider with LifterLMS active
    https://www.dropbox.com/s/t5eq1vrwvk209ta/lmsegf2.PNG?dl=0

    And here is the system report:

    WordPress
    -------------------------------------------
    
    Home Url: https://xxxxxxxxxxxxx
    Site Url: https://xxxxxxxxxxx
    Login Url: https://xxxxxxxx/wp-login.php
    Version: 5.2.3
    Debug Mode: No
    Debug Log: No
    Debug Display: Yes
    Locale: en_US
    Multisite: No
    Page For Posts: Blog (#52) [https://xxxxxxxxxxxxxxxx/]
    Page On Front: Home (#50) [https://xxxxxxxxxxx/]
    Permalink Structure: /%postname%/
    Show On Front: page
    Wp Cron: Yes
    
    Settings
    -------------------------------------------
    
    Version: 3.35.1
    Db Version: 3.35.1
    Course Catalog: Course Catalog (#54) [https://xxxxxxxxxxxx/]
    Membership Catalog: Membership Catalog (#55) [https://xxxxxxxxxxxxxxx/]
    Student Dashboard: Dashboard (#57) [https://xxxxxxxxxxxx/]
    Checkout Page: Purchase (#56) [https://xxxxxxxxxxxxxxxxx]
    Course Catalog Per Page: 9
    Course Catalog Sorting: menu_order
    Membership Catalog Per Page: 9
    Membership Catalog Sorting: menu_order
    Site Membership: Not Set
    Courses Endpoint: my-courses
    Edit Endpoint: edit-account
    Lost Password Endpoint: lost-password
    Vouchers Endpoint: redeem-voucher
    Autogenerate Username: yes
    Password Strength Meter: yes
    Minimum Password Strength: strong
    Terms Required: no
    Terms Page: Not Set
    Checkout Names: required
    Checkout Address: required
    Checkout Phone: optional
    Checkout Email Confirmation: yes
    Open Registration: no
    Registration Names: required
    Registration Address: optional
    Registration Phone: hidden
    Registration Voucher: optional
    Registration Email Confirmation: no
    Account Names: required
    Account Address: required
    Account Phone: optional
    Account Email Confirmation: yes
    Confirmation Endpoint: confirm-payment
    Force Ssl Checkout: no
    Country: US
    Currency: USD
    Currency Position: left
    Thousand Separator: ,
    Decimal Separator: .
    Decimals: 2
    Trim Zero Decimals: no
    Recurring Payments: no
    Email From Address: xxxxxxxxxxxxxxxxxxxxx
    Email From Name: Elementor
    Email Footer Text: 
    Email Header Image: 
    Cert Bg Width: 800
    Cert Bg Height: 616
    Cert Legacy Compat: no
    
    Gateways
    -------------------------------------------
    
    Manual: Disabled
    Manual Logging: 
    Manual Order: 1
    
    Server
    -------------------------------------------
    
    Mysql Version: 5.7.23
    Php Curl: Yes
    Php Default Timezone: UTC
    Php Fsockopen: Yes
    Php Max Input Vars: 1000
    Php Max Upload Size: 256 MB
    Php Memory Limit: 256M
    Php Post Max Size: 260M
    Php Soap: Yes
    Php Suhosin: No
    Php Time Limt: 30
    Php Version: 7.2.22
    Software: Apache
    Wp Memory Limit: 40M
    
    Browser
    -------------------------------------------
    
    HTTP USER AGENT: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.132 Safari/537.36
    
    Theme
    -------------------------------------------
    
    Name: Ashe
    Version: 1.9.1
    Themeuri: https://wp-royal.com/themes/item-ashe-free/
    Authoruri: https://wp-royal.com/
    Template: 
    Child Theme: No
    Llms Support: No
    
    Plugins
    -------------------------------------------
    
    Easy Google Fonts: 1.4.4
    LifterLMS: 3.35.1
    
    Integrations
    -------------------------------------------
    
    BbPress: No
    BuddyPress: No
    
    Template Overrides
    -------------------------------------------
    Plugin Support Natalie

    (@nrherron)

    Hi @lifesgood,

    Thank you for the screenshots and system report!

    I tested LifterLMS with Google Fonts and didn’t encounter the same issue on a test site. This may mean that it has to do with something in the theme. If you turn Google Fonts off while leaving LifterLMS on do you see the same issue?

    Can you provide a screenshot of the settings you have for Google Fonts as well? Does it make a difference with the settings in Google Fonts being set or is it just with the plugin turned at all.

    Let us know if it helps to match the settings or if the conflict exists with just LifterLMS turned on and we will continue to investigate!

    Thanks and take care,

    Bree

    (@lifesgood)

    Hi Natalie, thanks so much for your reply; it’s always a nice experience when I have to reach out to the LifterLMS team!

    The problem happens regardless of the theme (I’ve tried three).

    The problem lies within Dashboard > Appearance > Customize > Typography > Theme Typography AND Dashboard > Appearance > Customize > Typography > Default typography.

    Therefore, I can’t deactivate Easy Google Fonts because then the Theme Typography and Default Typography tabs wouldn’t exist. If I delete my ‘test’ setting (shown in the screenshot below) it still happens.

    Here’s a screenshot of the Easy Google Fonts settings: https://www.dropbox.com/s/xadkko6u0i5108n/lms3.PNG?dl=0

    And:
    https://www.dropbox.com/s/1ppog0jtideucnq/lms4.PNG?dl=0

    However, if I try to change another colour setting within the Customizer (Eg: Dashboard > Appearance > Customize > Colors it works OK with LifterLMS and EGF both active. So it’s just the colour settings within the Easy Google Fonts customizer tab that doesn’t work when LifterLMS is active (hope that makes sense!).

    • This reply was modified 3 months, 1 week ago by Bree.
    Plugin Support Natalie

    (@nrherron)

    Hi @lifesgood,

    I apologize for the delay! Thank you for the screenshots and details!

    We were trying to dig into this problem and do some testing! We think there is likely a Javascript error happening on the page that is causing the glitch with the slider.

    There is some information here on how to use your browser to diagnose javascript errors: https://wordpress.org/support/article/using-your-browser-to-diagnose-javascript-errors/ could you send us a screenshot of what you see on the console when you open the slider?

    Let us know if you have any questions about this process that we can help with!

    Thanks and take care,

    Bree

    (@lifesgood)

    Hi Natalie,

    Thank you so much for your assistance! I have followed your instructions to diagnose javascript errors.

    First, I tried looking at the issue in Internet Explorer/Edge to make sure it wasn’t a browser issue. It wasn’t, and the same issue occurred.

    Then, I went back to Chrome and looked at the console. There were no errors there.

    Then, I did an ‘Empty cache and hard reload” as the article you linked to on javascript errors also suggested re-loading the page.

    This FIXED the issue on my test site in Chrome, and for some reason also fixed it in Explorer/Edge even though I did not empty ‘cache and hard reload’ that browser.

    However…

    This was all just on a test site I’d recreated in trying to solve the issue (it only had 2 plugins: Easy Google Fonts and Lifter LMS). So then I went back to my main site I’m building which is where I first noticed the issue. I repeated the steps outlined above, but the issue was not resolved.

    So here are screenshots from my main site, showing the console:

    1. Screenshot showing console with LifterLMS activated – and the problem exists
    https://www.dropbox.com/s/8hsfelvd0kbnsr5/lmsactived.PNG?dl=0

    2. Screenshot showing console with LifterLMS deactivated – and the problem doesn’t exist
    https://www.dropbox.com/s/ot3qkb88owu4jea/lmsdeactived.PNG?dl=0

    So… it’s confusing! Any suggestions? If it were just for myself, I wouldn’t be even using the customizer or Easy Google Fonts, but it’s for client sites that need it. Thanks in advance 🙂

    Plugin Support Natalie

    (@nrherron)

    Hi @lifesgood,

    Thank you for the screenshots!

    I’m sorry that fix didn’t work on the main site!

    Can you provide us with a list of the other plugins that are active on the main site? The red in the console means there’s Javascript errors.

    Since the test site only had two plugins active, and was able to function properly after a hard reset, I’m wondering if there’s some conflict between LifterLMS and a separate plugin on the main site.

    We’ll get to the bottom of this for you!

    Let us know if you notice any further issues!

    Thanks and take care,

    Hi Natalie, and thank you again for your assistance.

    My main site has a lot of plugins, but even when they’re all active – except for LiferLMS – I don’t have the issue mentioned above; it’s only when LifterLMS is active that the issue occurs.

    Right now I only have LifterLMS and Easy Google Fonts active on my main site and this is the screen shot of the problem: https://www.dropbox.com/s/o09sgdfxemn9i16/lmsmain.PNG?dl=0

    I’ve cleared the cache multiple times on my main site, to no avail 🙁

    Plugin Support Natalie

    (@nrherron)

    Hi @lifesgood,

    I apologize again for the long delay in response!

    Thank you for the screenshot!

    It looks like there is a javascript error with CKEditor. Are you using CKEditor and if so is there a way you can turn it off to see if this removes the javascript error and gets Easy Google Fonts loading correctly?

    If you’re not able to get around that javascript error let us know!

    Thanks and take care,

    Hello, and thank you Natalie.

    I am not using CKEditor – at least not that I’m aware of, unless it is part of a plugin? But then, the only two plugins I have active are LifterLMS and Easy Google Fonts.

    Plugin Author Thomas Patrick Levy

    (@thomasplevy)

    @lifesgood

    CKEditor is a WYSIWYG editor, here’s the website: https://ckeditor.com/

    I don’t know where it’s coming from on your site. I assumed it was maybe bundled with your theme but I don’t see any evidence of that. It’s NOT part of LifterLMS (I would be the person who would know if we had a dependency like that and we don’t!).

    I’ve setup a live site to attempt to recreate this issue and I’m not able to find a way to recreate this. With your theme, LifterLMS, and Easy Google Fonts I’m not seeing the error you’re seeing.

    You can see the temporary test site here: http://jubilant-mandrill.w5.poopy.life/

    Admin credentials are in the header, you can login to see these 3 things interacting properly.

    I’m not entirely sure how to proceed. I’m very sorry you’re having this issue but it’s terribly difficult for me to fix issues I can’t reproduce.

    If you can help me get this temporary site into a state where the issue is recreate able that would be very helpful but if I can’t setup a test case I can’t fix it… Especially since the error you’re seeing is not coming from Easy Google Fonts, your theme, or our plugin.

    One last thing you could check would be browser extensions. Most browser extensions work exclusively in Javascript and I’ve seen weird issues where a browser extension would cause bugs like this. Perhaps try a different browser or disable all your extensions (temporarily) and see if that fixes the problem.

    My apologies,

    Bree

    (@lifesgood)

    Hello and thank you so much for your reply. I am sorry for the delay in mine – I have been without internet for almost a month. I will look into this and get back to you. Thanks again.

    Bree

    (@lifesgood)

    I am sending a support request via lifterlms.com. Thank you.

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.