• Resolved digbymaass

    (@digbymaass)


    In WP Download Manager’s classic editor view there are buttons that hide/reveal settings – Package Settings: Package settings | Lock Options | Icons. Since v6.13 of StopBadBots (and I found this out after a lot of reverting) these buttons no longer function.

    The inspector shows that your bootstrap js is loading into the editor page as well as Download Manager’s bootstrap js. If I disable your bootstrp js the buttons function again.

    Download Manager button event:

    /download-manager/assets/bootstrap3/js/bootstrap.min.js?ver=f067a50be8e70f7a4c0f9ec4927f2895
    
    function(c) {
      c.preventDefault(), b.call(a(this), "show")
    }

    Stopbadbots button event:

    /stopbadbots/assets/js/bootstrap.bundle.min.js?ver=f067a50be8e70f7a4c0f9ec4927f2895
    
    function(t) {
      t.preventDefault(), Wi._jQueryInterface.call(p(this), "show")
    }

    You can view the whole thread here including their suggestion that

    “…Stop Bad Bots plugin should not interfere with the wpdm page on the admin side, you may need to contact that plugin author”

    I hope this can be resolved as I want to carry on using both plugins!

    • This topic was modified 3 months, 3 weeks ago by digbymaass.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author sminozzi

    (@sminozzi)

    Hi,
    Looks like both plugins uses botstrap.js, then maybe is a conflict. We use botstrap to manage our visitors table.
    I will run a test with that plugin and let you know tomorrow.
    Cheers,
    Bill

    Plugin Author sminozzi

    (@sminozzi)

    Hi Digbymaass,

    I found a solution. I will enqueue bootstrap only in our dashboard page.
    I will add that on the next plugin version.
    For while, you can just disable the load of bootstrap like you did.

    Thanks for use our plugin.
    Cheers,

    Bill

    Thread Starter digbymaass

    (@digbymaass)

    Good plan!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.