Support » Plugin: SiteGround Security » Conflict with Divi Builder

  • Resolved schwindt14

    (@schwindt14)


    I wanted to report a conflict we noticed that must have occurred with a recent update of SiteGround Security.

    The Divi Visual Builder would enable fine but when trying to edit or add modules, the screen would go blank and everything would disappear, so it was impossible to edit anything.

    After standard plugin conflict troubleshooting, we found that disabling SiteGround Security allowed everything to function as normal.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    All test show SGS works flawlessly with Divi. Please, provide your URL so we can look further into it.

    Plugin Author Stoyan Georgiev

    (@stoyangeorgiev)

    Marking as resolved due to no reply.

    Thread Starter schwindt14

    (@schwindt14)

    Hello, I apologize for the late response. I have marked this one “not resolved” and will provide any info you need.

    I now have this happening on several of my Divi websites. The visual builder is enabled and when I try to add a module in Divi or open module/section/row settings modals, the content all disappears.

    Here is an example website: newageindustrial.com

    SiteGround Security is disabled currently because I have to be able to modify the site pages. The same thing happened on grm.net and notesofahermit.com.

    Thread Starter schwindt14

    (@schwindt14)

    I will also add that this problem began this week, and Divi released a significant update for their theme that altered performance in many ways. I am sure your plugin works well with Divi generally (I never had problems before), but is it possible that you have not tested your plugin with the recent Divi update?

    Plugin Author Stoyan Georgiev

    (@stoyangeorgiev)

    Hey there @schwindt14 ,

    Would it be possible to temporarily activate the plugin and provide exact steps to replicate the issue?

    Kind regards,
    Stoyan

    Thread Starter schwindt14

    (@schwindt14)

    Sure, I will try to keep it activated as much as I can today but I do need to edit intermittently so it’ll be deactivated at certain times.

    In the meantime, here is a video showing you exactly what is happening:

    https://screencast-o-matic.com/watch/crjT22VQcsO

    Let me know if that helps.

    I realize that this message is rarely necessary, but I have also been having the same problem with Divi and Siteground Security so it’s not only him that’s having this issue.

    Plugin Author Stoyan Georgiev

    (@stoyangeorgiev)

    Hey there @megidoflame,

    Would it be possible to start a new thread and provide details such as site URL, steps to replicate the issue, and the SiteGround Security plugin being active?

    @schwindt14 Would it be possible to enable the SiteGround Security Plugin?

    Thread Starter schwindt14

    (@schwindt14)

    Hi Stoyan! I would definitely like to help you investigate, however my fulltime job is updating/managing this website and so I am required to make edits throughout the day and cannot have the plugin enabled while I am working. However, if you were able to give me a timeslot of several hours during the day, I could enable it for you during a specific time. OR, I could enable it when I go home for the day at 5PM CST (United States) and that may be good enough for your time zone to troubleshoot when I am out of the office. Then I would disable it again at 8 AM CST. If that works for you, let me know and I will enable it at 5PM CST today.

    Plugin Author Stoyan Georgiev

    (@stoyangeorgiev)

    Hey there @schwindt14,

    The time frame you specified will do fine! Thank you very much for your cooperation!

    Kind regards,
    Stoyan

    Plugin Author Stoyan Georgiev

    (@stoyangeorgiev)

    Hey there @schwindt14,

    We checked the issue, but could not replicate the issues you were experiencing( the ones you’ve recorded in the video ).

    There is a high probability that the issue may be caused by an extension in your browser, since we checked with Chrome, without any extensions enabled, and no issues were present whatsoever.

    I would suggest checking in an incognito mode, without any extensions enabled. If you don’t experience the issues anymore, I would suggest checking in with Divi or the extensions developers on the matter.

    Once again, thank you for your assistance on the matter.

    Kind regards,
    Stoyan

    Thread Starter schwindt14

    (@schwindt14)

    You are indeed correct. I tried it in an incognito window in Chrome and it worked just fine. Very strange. I will start enabling/disabling extensions to see which one is running into trouble. Thank you for your help.

    Plugin Author Stoyan Georgiev

    (@stoyangeorgiev)

    @schwindt14,

    I am glad that we managed to locate the exact issue for that. Would it be possible to tell us the name of the extension that is causing this issue, when you locate the exact one?

    Kind regards,
    Stoyan

    schwindt14 did you ever figure out what extension in Chrome was causing your problem? I ran into the same issue as well.

    G.L.

    Thread Starter schwindt14

    (@schwindt14)

    I did not, I just ended up leaving the plugin disabled just until today, when I turned it back on. So far, so good, so it is possible that one or the other party altered something that resolved the issue. We’ll see!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Conflict with Divi Builder’ is closed to new replies.