Support » Plugin: Plugin Organizer » Conflict with Contact form 7

  • Hi,
    when validating form, Contact form 7 spinning arrow icon never stops…

    here is the error it gaves in Chromium console
    jquery.js?ver=1.12.4:4 POST http://XXX/wp-json/contact-form-7/v1/contact-forms/158/feedback 401 (Unauthorized)

    I tried deactivating Plugin organizer and it works like a charm, so somehow your plugin is only blocking Ajax as the form display as wanted?

    Any help?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Jeff Sterup

    (@foomagoo)

    Sounds like you deactivated contact form 7 globally. You need to create a plugin filter with http://XXX/wp-json/contact-form-7/v1/contact-forms/ as the permalink and select also affect children.

    Hello,
    tried your solution, didn’t work, so i removed the ‘disabled globally’ option and that worked.
    It amaze me because not so long ago (talking about few weeks) the combo contact form 7 + plugin organizer was working like a charm.
    i noticed this bug on few sites i manage ; something has changed…

    thanks anyway

    Plugin Author Jeff Sterup

    (@foomagoo)

    Did you enable fuzzy url matching on the Plugin Organizer settings page? I tried the solution I gave you on my test site and it works. Globally disabled Contact Form 7, created a plugin filter with Contact Form 7 enabled, set the permalink to http://www.mytestingdomain.com/wp-json/contact-form-7/v1/contact-forms/, and checked the also affect children checkbox. I did just notice that you are getting a 401 response and not a 404 response which is odd. Might just be your server configuration. I get a 404 response when Contact Form 7 is disabled globally.

    That helped me thanks

    juanjobt

    (@juanjobt)

    Hi, I have a similar problem, but with a response of “500 (Internal Server Error)”

    POST http://www.enuk.es/wp-json/contact-form-7/v1/contact-forms/2061/feedback 500 (Internal Server Error)
    send	@	jquery.js?ver=1.12.4:4
    ajax	@	jquery.js?ver=1.12.4:4
    wpcf7.submit	@	scripts.js?ver=5.0.1:344
    (anonymous)	@	scripts.js?ver=5.0.1:53
    dispatch	@	jquery.js?ver=1.12.4:3
    r.handle	@	jquery.js?ver=1.12.4:3

    Page test: http://www.enuk.es/test

    I have not understood very well how you have solved it. You could explain to me in more detail the process to fix it. Thank you very much.

    hilmon

    (@hilmon)

    I’m also having the same “500 (Internal Server Error)” error … /wp-json/contact-form-7/v1/contact-forms/7328/feedback 500 (Internal Server Error)

    @juanjobt I can see from your test page that you fixed the issue?

    I simply enabled cf7 globaly and dissabled it on all post types. On the page with cf7 I enabled it and it work very good. This way it is almost globally disabled.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.