Support » Plugin: Redis Object Cache » Conflict with cache system in freemius

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    What is Freemius?

    
    RedisException: read error on connection to 127.0.0.1:6379
    

    Indicates that your Redis server is not up and running.

    Thread Starter Rookie

    (@alriksson)

    What is Freemius?

    https://freemius.com/ “A managed eCommerce engine to sell and market freemium and premium WordPress plugins & themes. Secure Checkout, Software Licensing, Subscriptions” Just like Easy Digital Download.

    RedisException: read error on connection to 127.0.0.1:6379
    Indicates that your Redis server is not up and running.

    Ok have not experienced this before using the same managed host and redis through them, cloudways platform and your plugin.
    https://www.cloudways.com/blog/install-redis-cache-wordpress/

    Seeing no issues once running redis-cli monitor but let me know.

    Here is from the Diagnostics tab of your plugin:

    Status: Connected
    Client: PhpRedis (v5.3.1)
    Drop-in: Valid
    Disabled: No
    Filesystem: Working
    Ping: 1
    Errors: []
    PhpRedis: 5.3.1
    Predis: Not loaded
    Credis: Not loaded
    PHP Version: 7.4.12
    Plugin Version: 2.0.15
    Redis Version: 5.0.3
    • This reply was modified 1 year, 2 months ago by Rookie.
    Plugin Author Till Krüss

    (@tillkruess)

    How often does the error occur?

    Thread Starter Rookie

    (@alriksson)

    Reports every day in the error log. Also see a lot of errors in the log with WPML, will try to report to them as well. Or do you find issues in the redis installation on the server?

    [Tue Nov 24 15:30:06.741597 2020] [proxy_fcgi:error] [pid 4372] [client hidden-ip:37756] AH01071: Got error 'PHP message: RedisException: read error on connection to 127.0.0.1:6379 in /mnt/data/home/hidden-number.cloudwaysapps.com/hidden-folder/public_html/wp-content/object-cache.php:1357\nStack trace:\n#0 /mnt/data/home/hidden-number.cloudwaysapps.com/hidden-folder/public_html/wp-content/object-cache.php(1357): Redis->get()\n#1 /mnt/data/home/hidden-number.cloudwaysapps.com/hidden-folder/public_html/wp-content/object-cache.php(114): WP_Object_Cache->get()\n#2 /mnt/data/home/hidden-number.cloudwaysapps.com/hidden-folder/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/utilities/class-wpml-wp-cache.php(31): wp_cache_get()\n#3 /mnt/data/home/hidden-number.cloudwaysapps.com/hidden-folder/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/url-handling/converter/class-wpml-url-cached-converter.php(30): WPML_WP_Cache->get()\n#4 /mnt/data/home/hidden-number.cloudwaysapps.com/hidden-folder/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/url-handling/wpml-url-filters.class.php(291): WPML_URL_Cached_Converter->convert_url()\n#5 /m...',

    Tue Nov 24 15:30:06.956368 2020] [proxy_fcgi:error] [pid 4376] [client hidden-ip:37764] AH01071: Got error 'PHP message: RedisException: read error on connection to 127.0.0.1:6379 in /mnt/data/home/hidden-number.cloudwaysapps.com/hidden-folder/public_html/wp-content/object-cache.php:1357\nStack trace:\n#0 /mnt/data/home/hidden-number.cloudwaysapps.com/hidden-folder/public_html/wp-content/object-cache.php(1357): Redis->get()\n#1 /mnt/data/home/hidden-number.cloudwaysapps.com/hidden-folder/public_html/wp-content/object-cache.php(114): WP_Object_Cache->get()\n#2 /mnt/data/home/hidden-number.cloudwaysapps.com/hidden-folder/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/utilities/class-wpml-wp-cache.php(31): wp_cache_get()\n#3 /mnt/data/home/hidden-number.cloudwaysapps.com/hidden-folder/public_html/wp-content/plugins/wpml-string-translation/classes/filters/strings-filter/class-wpml-register-string-filter.php(353): WPML_WP_Cache->get()\n#4 /mnt/data/home/hidden-number.cloudwaysapps.com/hidden-folder/public_html/wp-content/plugins/wpml-string-translation/classes/filters/strings-filter/class-wpml-register-string-filter.php(186): WPML_Register_String_Filter-...',

    Plugin Author Till Krüss

    (@tillkruess)

    Its a common error: https://github.com/phpredis/phpredis/issues/1543

    Maybe your Redis instance is running out of connections. I’d suggest asking your hosting provider for assistance.

    Thread Starter Rookie

    (@alriksson)

    Okay so you say all these issues might be related to the Redis instance is running out of connections?

    I will ask the host and see what their support say regarding this.

    Plugin Author Till Krüss

    (@tillkruess)

    Yeah, the issue is on the side of Redis Server, not WordPress.

    Thread Starter Rookie

    (@alriksson)

    Did you tried contacting the erropix-hydrogen-pack author and ask for the timeout setting for redis. Usually it requires that the code level changes required to increase the timeout https://stackoverflow.com/questions/18072407/php-redis-timeout-read-error-on-connection Also see as per the suggestion in stackover flow it is set to 0 which is recommended.

    From the hosting, but this should not be needed or be specified per plugin.

    I also read it should eb set to 0 but the use of freemius sdk cause it to timeout?
    While for me it seems like object-cache.php is the responsible for cache handling, Freemius do not integrate with Redis.
    I checked the Freemius class and found it use wp_cache_set which is standard WordPress API for cache.

    • This reply was modified 1 year ago by Rookie.
    Plugin Author Till Krüss

    (@tillkruess)

    If PHP/WP can’t communicate with Redis Server, it’s an issue with your Redis Server setup and not related to this plugin.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Conflict with cache system in freemius’ is closed to new replies.