WordPress.org

Forums

Events Manager
[resolved] Conflict with Buddypress Groups Extras - again (6 posts)

  1. e13
    Member
    Posted 11 months ago #

    Hi! I just updated to the last Events Manager version and met exactly the same bug I edited manually (and noticed it somewhere here) about 4 months ago.

    The problem is: Enevts Manager blocks output of extra group pages. The group pages are always empty if both Events Manager and Group Extras are installed.

    I solved this problem by adding
    else echo $page_content;
    to line 110 just before
    $content = ob_get_clean();

    Just the same trick has worked now.

    https://wordpress.org/plugins/events-manager/

  2. solhuebner
    Member
    Posted 11 months ago #

    Good point.

    Thank you!

  3. jturet
    Member
    Posted 3 months ago #

    This works, can we get this fix implemented into future releases?

  4. rmcourtage
    Member
    Posted 3 months ago #

    Hello e13,

    Have you been able to treat the problem in version 5.5.6 of event manager ?
    I cannot find the line of code you are referring to in your solution.

    Thank you in advance

  5. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 month ago #

    sorry for not getting back to you here. the problem with the solution (which is destined for events-manager/em-events.php) is that you're echo'ing page content within a filter, which we shouldn't have to do.

    The line $content = ob_get_clean() means that anything output at this point will be returned a few lines down and the_content filter will then appropriately output the $page_content.

    We need to test this out though, I think this may be a settings issue rather than a bug. That section of code only gets triggered if you're visiting a WP page which you've assigned to be overwritten with our formatting in the Events > Settings > Pages section. I tried installing the plugin and I don't see this error.

  6. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 6 days ago #

    tried again, still couldn't replicate. that said, there's lots of settings in extras so it could be a combination.

    I'm marking this resolved but will keep subscribed to comments

    if the conflict still hasn't been resolved please let us know here, and provide some screenshots with settings in Extras and pages you expect to see (with EM disabled) vs. what shows up. if we can replicate it, we can figure out for sure if EM is causing this (which at the moment i've got my doubts).

Reply

You must log in to post.

About this Plugin

  • Events Manager
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic