Support » Plugin: Interactive Geo Maps » Conflict with Avada Fusion live builder

  • I’m using Avada theme.

    The plugin is great but as soon as i activate it, Avada Live Builder stops working. After reseting Avada caches i can open the live-edit-mode once but as soon as i close it i can’t open it again so i have to reset caches again. Seems to be some JS loading issue.

    Thinking about buying a license but only if it works with Avada.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Carlos Moreira

    (@carlosmoreirapt)

    Hi @nelidius
    I tried with WordPress 5.5 and Avada 7.0.1 with my plugin and I didn’t come across any issue. I could use both the Avada Live Builder and the Avada Builder, without problems, even trying to edit multiple times to see if any problem would come up. It could be something else interfeering or maybe different version issues? I used Chrome, by the way, but that shouldn’t interfere. You could try disabling some other plugins to see if it could be the case of a third plugin in combination with mine causing the issue.
    Greetings, Carlos

    Thanks, Carlos.
    I tried to deactivate the other plugins one by one and it seems to be Yoast SEO which interferes with your plugin. As soon as i deactivate it, it works properly ans stops working again after the activation. Would you please check it? Thank you.
    Cheers, Denis

    Plugin Author Carlos Moreira

    (@carlosmoreirapt)

    Hi @nelidius
    I tested with the following setup:

    WordPress 5.5
    Avada 7.1
    Yoast 14.7
    Interactive Geo Maps 1.2.10

    And I couldn’t replicate the issue you describe. I’m able to use the avada live builder in different pages, several times.

    It could be a particular setting from Yoast that could cause a conflict. Are you using any particular setting that would be out of the ordinary or different from the usual default values?

    I’m interested in understanding what could be causing the issue, but without being able to replicate it it’s hard to understand. Do you see any errors in the browser console?

    My setup is:

    WordPress 5.5
    Avada 7.0.2
    Yoast 14.7.
    Maps 1.2.10

    I’ve also tried to delete Yoast and reinstall it, but unfortunately it didn’t help. I’m using standard settings in Yoast.

    One more interesting issue: after applying some changes to Avada options and saving them, live builder works once even if Yoast is activated. After the first one it stops working again until i apply any changes to Avada options again or just press the “save changes” button without changing something.

    So it seems like Avadas caches also have something to do with the issue. But without Yoast plugin Avada and Maps work perfectly together…

    Plugin Author Carlos Moreira

    (@carlosmoreirapt)

    I tried some random edits and option changes, but couldn’t replicate the issue with your same versions. Without being able to replicate the issue I can’t debug to find the cause.

    I’ll keep this issue in mind, but there’s not much I can do at the moment. I would be interested to solve this, since both Avada and Yoast are very popular products and I want to guarantee it works together with my plugin, but I’ve got my hands tied.

    Thank you for the detailed info you’ve been providing, it will be helpful to follow up on this in the future should the problem arise again. But at the moment I won’t be able to follow up on this, but will keep an eye on it, if some other user reports the same.

    nelidius

    (@nelidius)

    Thanks for you reply, I totally understand you! Well, let’s see, maybe some Yoast update in the future will fix it.

    Fun fact: I also tried to uninstall Yoast and install All in one SEO, but as soon as i activate All in one SEO i got the same issue….

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.